It looks like you're using an Ad Blocker.

Please white-list or disable AboveTopSecret.com in your ad-blocking tool.

Thank you.

 

Some features of ATS will be disabled while you continue to use an ad-blocker.

 

07 Equinox problem.

page: 1
0

log in

join
share:

posted on Sep, 11 2015 @ 09:04 PM
link   
I have an 07 Equinox that's giving me headaches.
First it was the throttle body/TB sensor. It was removed, cleaned and the sensor replaced. Next, it was plug wires. New ones installed. Now, the engine is running rough, hesitating, gas mileage has dropped and a strong sulfur/rotten egg smell from the exhaust. The vehicle has 136,000 miles, so I'm really starting to suspect the catalytic converter. Everything I find on the internet points to that also. It does mention other problems, but most folks say they replaced the CC and their troubles were over.
Opinions?




posted on Sep, 11 2015 @ 09:06 PM
link   
a reply to: DAVID64

Is it giving you any engine or diagnostic codes? If you don't have the reader lots of auto parts shops will read it for you for free.

Have you checked the oxygen sensors?



posted on Sep, 11 2015 @ 09:15 PM
link   
a reply to: cmdrkeenkid

I'm gonna run to the shop tomorrow and get them to hook it up to a reader. Yeah, I'm thinking I'll do a "cheapest first" fix. Replace the oxygen sensor and if that doesn't help, go ahead with the CC. I'll probably go ahead and replace the CC anyway. With 136,00 miles on it, it's only a matter of time [ and not much ] till it needs it.

ETA - All I'm getting is "check engine" and "service stabilitrack" idiot lights. I know that RPM will effect the stabilitrack so.....
edit on 11-9-2015 by DAVID64 because: (no reason given)



posted on Sep, 11 2015 @ 09:17 PM
link   
a reply to: DAVID64

Did you allow for orbital precession?

(Just kidding, I'm from a different country and am not familiar with that model).




posted on Sep, 11 2015 @ 09:20 PM
link   
a reply to: DAVID64

Not sure on that model, but there might be more than one oxygen sensor. If any one is off, it can throw everything off. And the party might be cheaper, but they're not necessarily easier to replace.

But, yeah, once you start getting over the 100k miles it's time to start thinking about replacing the cat anyway.



posted on Sep, 11 2015 @ 09:49 PM
link   
a reply to: DAVID64

There was a recall on 2007 Equinox for fuel pump leakage. Might want to email GM your VIN or check with a Chevy dealer.The CC and oxygen sensors may not be your only problems.

Good luck
edit on 11-9-2015 by M5xaz because: typo



posted on Sep, 11 2015 @ 09:51 PM
link   
a reply to: M5xaz

Forgot to add, seal failure would account for dropping gas milleage.

I would get it checked pronto - risk of fire....
Good luck



posted on Sep, 11 2015 @ 09:59 PM
link   
a reply to: M5xaz

yeah, took it in and got that fixed when the smell of gas got so strong, I started to look for a spill on the ground. The fuel pump was cracked and they replaced it no charge.



posted on Sep, 14 2015 @ 09:03 PM
link   
GM 60° V6? Also check the MAF sensor. It can make a car bog badly while still being in range to not throw a code. You basically lose power on the top end, and it's peculiar as it's just like hitting a rev limiter. (In my case I thought it was something odd in the ECU or transmission at first, because there is a low rev-limiter for park/neutral.) Let it go long enough, and there you are with a clogged cat and possibly worse problems.

My car has the LA1 (so been there through experience), but it looks like the Equinox for your year got the version or two that came after that. Hopefully they fixed the LIM gasket and EGR stuff with the 3.4L by 2007. Yet I wouldn't be surprised if similar things are going on.

Other than a few odd bugs that can confuse you if you don't know them, those engines are pretty reliable otherwise. Internal geared cams and such almost like a throwback to the old way, upside is no chance of bent valves due to timing, etc.



posted on Sep, 15 2015 @ 05:42 AM
link   
a reply to: pauljs75

No such luck. Had to replace the EGR about a month ago.
edit on 15-9-2015 by DAVID64 because: (no reason given)



posted on Oct, 30 2015 @ 09:38 AM
link   
Unbelievable to me that is!




top topics



 
0

log in

join