It looks like you're using an Ad Blocker.

Please white-list or disable AboveTopSecret.com in your ad-blocking tool.

Thank you.

 

Some features of ATS will be disabled while you continue to use an ad-blocker.

 

Need help with black screen nvidia driver problem. thanks

page: 1
0

log in

join
share:

posted on Dec, 28 2011 @ 08:48 AM
link   
Turned pc on today and after loading up I got a black screen that went to power save. Tried it off and on a few times with same results. I phoned a friend who said switch to safe mode and change the screen resolution. Same thing happened on normal mode. Phoned him again and he said go to safe mode again and disable nvidia driver to see what happens. Well, I did that and went to normal mode and it's now all working again.

Problem is, I've been downloading SWTOR since last night and now when I try to log into game it says my pc's not compatible with the game, obviously because I have no driver now. Before the black screen problem with the driver I was getting a different black screen with the game saying my monitor was 'out of range'.

What can I do now? Been farting with this game and black screen problem for 21 hours now. PC ready to go out the window.

Thanks for any help.




posted on Dec, 28 2011 @ 08:53 AM
link   
Have you downloaded a latest driver for your video card?
Also clean your GFX card and your pc that is what was wrong when I had trouble. It sounds like your card is overheating and shutting down to save your card, find a program which monitors the temps of your card and processor to make sure.
edit on 28-12-2011 by boymonkey74 because: (no reason given)



posted on Dec, 28 2011 @ 09:03 AM
link   
Sounds like the new driver is the problem. Just roll back to an older driver this wouldn't be the first time Nvidia put out a driver that isn't compatible with all cards.



posted on Dec, 28 2011 @ 09:05 AM
link   
reply to post by wigit
 

Minimum specs for the game are here
www.swtor.com...

People experiencing vaguely similar problems
forums.nvidia.com...
forums.nvidia.com...
forums.nvidia.com...

Like monkeyboy says, a new driver might be the solution. Seeing as it's quite a new game I would guess there might be a few small problems to iron out.



posted on Dec, 28 2011 @ 09:18 AM
link   
Thanks guys. So I just keep the driver I have on disabled and download an older one. How would I recognise an old driver to download? Am I just looking for a smaller number? And no need for safe mode for all that?



posted on Dec, 28 2011 @ 09:23 AM
link   
reply to post by wigit
 


download the latest driver and make sure you get rid of the old driver with add/remove programs in your control panel and restart your comp, the display will be really big when you restart and then install the new driver, hope this helps fella



posted on Dec, 28 2011 @ 01:30 PM
link   
If you still are having this issue with the newest driver then remove the new driver through the control panel and download an slightly older version from nvidia. 280.## was a very stable version in my experience, otherwise you have to go too far back to the 187 range. The 'out of range' error is basically saying that your monitor was set to an invalid video setting. Like you set it to 1900x1080 but you monitor would only support up to 1600x900, make sure you have the correct resolution and the correct Hertz set. If you are only receiving this black screen while trying to start SWoR then try to load the launcher first and adjust the settings. If there is no launcher then find the ".ini" file, usually located in the 'My Documents' folder and open this with notepad and manually edit the resolutions.



posted on Dec, 28 2011 @ 03:32 PM
link   
I run Fedora Linux myself. There have been some problems with the
GeForce 290.53 beta driver. I had so much trouble with this driver that I went back to Fedora 15, which still uses the Legacy GPU Version (173.14.xx series) driver, and it works flawlessly. For a Windows user, I guess you would want to un-install the current driver, and install an older driver from the Nvidia website. I was unable to do this in Fedora 16, it would not allow me to roll back the driver.

Here is the Tech Support page: nvidia.custhelp.com...
edit on 12/28/11 by autowrench because: (no reason given)



posted on Jan, 3 2012 @ 03:25 AM
link   
I have had problems with the current driver. 285.62
Using Chrome and the black screen almost always happens when shockwave flash plugin crashes.

Putting the blackened pc into sleep mode and then back out restores the display.




top topics



 
0

log in

join