It looks like you're using an Ad Blocker.

Please white-list or disable in your ad-blocking tool.

Thank you.


Some features of ATS will be disabled while you continue to use an ad-blocker.


Help ATS via PayPal:
learn more

Linux Mint Problems

page: 1

log in


posted on Apr, 9 2016 @ 05:51 PM
I switched from Fedora 23 to Linux Mint 17.3 a few weeks ago as I had problems mounting a second drive at boot. In a previous thread several members tried to assist me but to no avail.

I decided to test drive a few distros and Linux Mint loaded my second drive and partitions, even on the live CD. I liked the feel so installed it and have been using it for a few weeks. Despite being really impressed with the distro I have several problems that I cannot solve despite hours of searching, reading and adjusting.

Graphics Card

I have a NVidia GT 720 passive card with 2GB DDR5 RAM. It worked perfectly with Fedora 23 but Linux Mint is not having any of it. On the standard install it was freezing randomly after logon. I got fed up of using Ctrl+Alt+F1 and Ctrl+Alt+F8. Logs did not show anything specifically. I used the synaptic package manager and uninstalled and reinstalled the latest packages from Ubuntu. Result: I could could not get past the boot splash screen.

In the end I took the card out and reverted to onboard graphics and the freezing stopped. So now I have a redundant 6 month old card which cost me £70. Has anyone managed to get a NVidia card to work with Linux Mint? I read about disabling nouveau but not sure if this is dismantling part of the operating system.


On connection it fails on TLS handshake. Searching this reveals the problem lies with my server which does not make sense as it worked perfectly with Fedora 23. I have opened Linux Mint firewall (UFW) to allow openvpn inwards which did not work. I temporarily disabled the firewall and this did not work either. I have port scanning detection/blocking on my server and every time I try to connect with openvpn I get blocked. This did not happen with Fedora. In my openvpn client config I explicitly state the port. Looking at GUFW I can see openvpn is trying to connect using random ports which does not make sense.

Reading this you are probably thinking why not go back to Fedora 23. The thing is I really like Mint and it excels in many other ways (speed for one).

Is Mint just very temperamental? Does it need to be stroked (tinkered) and nice things said to it for it to purr?

posted on Apr, 9 2016 @ 06:05 PM
I just recently installed Mint 17.3 to a partition on one of my hard drives, but I also just installed a new nVidia graphics card. Unfortunately with Mint (don't know about Ubuntu or any other distro), you have to use the "nomodeset" option to get basic video.

Then once Mint is installed, you can use Synaptic to get the nVidia drivers for your card. I'm still a Linux baby, so I can't help with another hard drive not being able to be mounted, but try to use "nomodeset" from the Live CD/USB to get basic video for your Mint install, then you can install your graphic drivers after Mint is installed.

edit on 9-4-2016 by _BoneZ_ because: (no reason given)

posted on Apr, 9 2016 @ 06:14 PM
Also with Mint 17.3, I noticed you can't use the command line with nano or even Gedit anymore to edit the defaults.list file to replace "totem" with VLC, for instance. You have to use the "Default Apps" in settings now.

You have no idea how many days, hours I spent on that, and even with some people in Linux IRC, and then it was as simple as using the Default Apps GUI in settings.

That's just one of the possible many changes that have come to Mint 17.3.

posted on Apr, 9 2016 @ 06:22 PM
Thanks for your advice. A new avenue for me to explore. I am determined to correct these issues.

You have no idea how many days, hours I spent on that, and even with some people in Linux IRC, and then it was as simple as using the Default Apps GUI in settings.

I spent nearly a whole day trying to correct mouse lag and it turned out that Mint did not like my mouse usb next to my bluetooth usb. I didn't even think to try it in another usb port as it was not a problem in Fedora.

posted on Apr, 9 2016 @ 06:43 PM
a reply to: Morrad

Just checking the basics... Did you install the proprietary Nvidia drivers?

posted on Apr, 9 2016 @ 06:49 PM

originally posted by: Hefficide

Just checking the basics... Did you install the proprietary Nvidia drivers?

I think he's talking about on first install, he's having issues. This is an issue with nVidia video cards on Linux. All I got was a black screen when I first installed Mint 17.3.

I had to re-install Mint using "nomodeset" to get very basic video drivers, and then once I could boot into Mint, only then could I install the proprietary nVidia drivers.

posted on Apr, 9 2016 @ 06:52 PM
a reply to: _BoneZ_

With one build of Ubuntu 16.04, the only way I could make it work at all was to install the proprietary drivers onto the flash drive prior to install on my 'nix partition.

In the 2-3 years I've been using Ubuntu and variants the Nvidia drivers have always been kind of difficult and pissy.

posted on Apr, 9 2016 @ 07:02 PM
a reply to: Hefficide

Yeah, I had to upgrade my Mint 16 install since I changed video cards, and have heard rave reviews about 17.3. And then when I installed 17.3 and got just a black screen, I wasn't about to put my old video card back in just to get video.

The first suggestion was to use "nomodeset" (out of several different options to get video) and that's what worked for me.

posted on Apr, 9 2016 @ 10:29 PM
I've been a Linux user for aeon's, and have mint on my computer.

I think it's either your distro or the card giving issues. Try and older mint distro maybe. I'm running a slightly older one on my I5 dual core with 2gb nvidia card with no issues whatsoever.

Linux can be painful at times with hardware compatibility. This has improved a lot in recent years with Android bursting into the scene, but basically anything new and exciting in the hardware world is given windows compatibility as its top priority and Linux is the poor 'we'll get around to it if and when we can be bothered cousin'

posted on Apr, 10 2016 @ 05:30 AM
Thanks guys.

I am going to put my card back in today and try the methods suggested.

I was able to uninstall nouveaux last night and download and install latest propriety drivers. Will see what happens when I put the card back in and boot.

posted on Apr, 10 2016 @ 09:14 AM
I managed to install the proprietary drivers by disabling nouveaux and stopping x-server. I rebooted and got to the login screen ok then Cinnamon crashed and went into fallback mode.

I am going to reinstall Mint but decided to download KDE Plasma to just check. That did not crash ... strange.

posted on Apr, 10 2016 @ 10:04 AM
a reply to: Morrad

On the Mint live CD, I had to choose recovery mode (because there was no "nomodeset" option), then back out of recovery and let it boot. That was the only way I could have video with low resolution.

And that's the way Mint installed (low resolution video, but there was video). I was then able to use Synaptic to install the nVidia drivers.

posted on Apr, 10 2016 @ 12:33 PM
I tried that with a fresh install and installed proprietary drivers downloaded from Nvidia site which also crashed cinnamon.

I tried another complete install and used the most current Nvidia package from synaptic manager instead and that froze.

While my card is connected, the initial boot after splash is to a blank screen and then on reboot it gets me to log in but with cinnamon crashing.

Spent the whole day on this grrrrr. I have took the card out. I am aware that Mint is not cutting edge like Fedora so will try again in a couple of months.

Thanks for your advice bud.

posted on Apr, 10 2016 @ 03:23 PM
a reply to: Morrad

With the Nvidia drivers, there are more than one and the latest may not be the correct choice. I can't dig at the moment, but off hand I'd guess that you would need a legacy driver - possibly the latest 3.58 or 3.04 build

posted on Apr, 10 2016 @ 04:47 PM
a reply to: Hefficide

I downloaded 3.61

I will take a look at the legacy driver you mention. Thanks

posted on Apr, 10 2016 @ 05:03 PM
a reply to: Morrad

I just found this link.

It looks like neither your GT720 card is supported yet, nor is 17.3 Mint. (Mint is just Ubuntu in a fancy dress basically)

I checked my system and I am 17.2 Mint with a Radeon RV730 card (not nvidia like I thought) This one worked straight out of the box for me.
edit on 10-4-2016 by markosity1973 because: (no reason given)

posted on Apr, 11 2016 @ 09:45 AM
a reply to: markosity1973

Thanks for this. I am going to wait a few months before trying again. Hopefully it will be supported by then.

Tbh I'm not a gamer. The reason I got the card was due to weird patterns appearing on the screen after 18months of normal use. Thinking it was a fault with the on-board graphics, I bought the card and the patterns were still there after installing it.. It was in fact the HDMI lead. As I had already put the card in I decided to keep it.

new topics

top topics


log in