It looks like you're using an Ad Blocker.

Please white-list or disable in your ad-blocking tool.

Thank you.


Some features of ATS will be disabled while you continue to use an ad-blocker.


java script must be enabled error for submitting post

page: 1

log in


posted on Apr, 19 2009 @ 02:34 PM
I just tried to reply to a friends thread this morning and found that there was an error, it said unable to submit because java script must be enabled. Well it is. And so I attempted to try all 3 browsers including safari, on all 3 computers. The same error. Then I went into my linux (mepis) partition and found the same error there. But went to another forum, signed in an did a quick post. So it does seem to be specific to ATS. And I tried numerous threads with the same thing, yet for some reason the post button seems operational for starting this thread.

[edit on 19-4-2009 by mystiq]

posted on Apr, 19 2009 @ 02:37 PM
Oh bother!
I hope this doesn’t stop you from posting.
I really enjoy your threads and always take moment to look and see what you’ve been up to!

I hope it all works out fine for you.


posted on Apr, 19 2009 @ 02:40 PM
Thank you, really appreciate you saying that. Sometimes I have to post then duck and dodge for a bit, because some of it takes courage.

Edit to add: it let me reply to this thread.
I shall check again on others. I've been trying for a couple hours now to solve this. Will update this as soon as I check.

No it still says the same thing.

[edit on 19-4-2009 by mystiq]

[edit on 19-4-2009 by mystiq]

posted on Apr, 19 2009 @ 03:24 PM
Ok, for some reason this suddenly cleared up and its solved. I was able to submit a post. Strange morning I've had here.

Perhaps a mod would close this thread for me. Thank you.

posted on Apr, 19 2009 @ 04:18 PM
Interesting... you were able to post without having JavaScript enabled? I thought the recent changes for a minimum character count in posts require JavaScript, and one couldn't post without it. Also, perhaps the "member tools" button at the top of the page doesn't work without JavaScript?

[edit on April 19th 2009 by Ian McLean]

posted on Apr, 19 2009 @ 04:45 PM
hm if it makes you feel any better, I had the same problem two days ago and java script IS enabled on my puter.

yesterday all was back to normal... must be a glitch :p

posted on Apr, 19 2009 @ 05:04 PM
It is enabled always, so I knew it was an error. I spent quite a while on it, and cleared my cookies over and over again. In any case, it all just started working suddenly so its a false alarm now, and probably a strange glitch for a while.

posted on Apr, 20 2009 @ 06:45 AM
The java script thing you are talking about is the word count... note how it says something to the extent of "cannot reply" when you first respond, but as you begin to type, the count goes from 100 [characters] to 0, and then it says "submit reply".

This is done to prevent / stop people from doing the one liners or little piddly responses.

posted on Apr, 20 2009 @ 07:00 AM
the ATS forum must use a basic form of 'JavaScript'...

because i post here without problems...
& i have refused 'Java' updates for over two years now....

(seems my ability to move jig-saw pieces got messed up with an update
awhile back & i had to uninstall that update to get back to puzzle solving)
? broken codes?
glad the problem resolved itself

posted on Apr, 20 2009 @ 10:17 AM
reply to post by St Udio

There's a common ambiguity, that Java is the same as JavaScript. That's not true - they're two very different languages. JavaScript support is built-in to the browser, and gets upgraded with new versions of it, whereas Java is usually implemented with a separate browser plug-in.

Java and Java Script share two very similar names, but they are completely
different languages that possess few commonalties. They differ both in their purpose and
the applications they can run. Java Script does not permit programmers to create stand
alone applications, or applications that can run by themselves that are not imbedded in
another language, while Java is a complex language that allows programmers to create
entire stand alone applications, or applications that run all buy themselves. Java Script is
a much simpler language, similar in structure to HTML, and thus, Java Script is much
easier to learn, but it must always be imbedded in another text, usually HTML.

posted on Apr, 20 2009 @ 12:00 PM
I don't know what it is, but it wouldn't let me post, said it could not submit. But I could start a thread here, which I hadn't thought I would be able to. And the _javascript thing is under this right now, so maybe it wasn't an error message. I had assumed it was related to the unable to submit button, but now that I notice its always there, I am probably wrong about it.

I already been posting, like everyone has, with this new word count, so it seemed to be a very strange glitch that was happening on all my browsers, all my computers, and all my OS's. But after clearing cookies many times, which may or may not have resolved it, it suddenly disappeared. That made me very happy.

[edit on 20-4-2009 by mystiq]

posted on Apr, 20 2009 @ 12:03 PM
It's not an "error message," but rather a simple notice that JavaScript must be enabled.

Everyone should be seeing it on all reply forms.

posted on Apr, 20 2009 @ 12:12 PM
I've been having that same problem. What I noticed is that if I hit PREVIEW first, read the message over, and then try to press SUBMIT REPLY, it won't work, it's as if the button is not there. Preview doesn't work again also.

I discovered to get around it all I had to do was add an extra character to the end of the post and then I could click the SUBMIT REPLY button.

AND, I just checked and the problem persists.

Likely a programming error at the ATS site. Try it. Try a reply and press preview and then, without adding more text to your post, try to press submit or preview again .. it won't work.

BTW, I'm using Firefox version 3.0.5 and Java Version 6 Update 6 (build 1.6.0_06-b02).

posted on Apr, 20 2009 @ 12:20 PM
LMAO.. I have been having that problem for days now. I woke up this morning wishing I could post asking how to fix this.. and BLAM.. someone did it for me. Thank you OP!

posted on Apr, 20 2009 @ 05:29 PM
I had the nearly identical problem with "preview post" that Divinorumus posted (also in Firefox 3.x with the ATS Javascript enabled). I noticed this problem about a week ago, and really have not been able to post all that time.

I'll try this post without "preview" first.

EDIT: Hm, that worked.

[edit on 20-4-2009 by rhunter]

top topics


log in