It looks like you're using an Ad Blocker.

Please white-list or disable in your ad-blocking tool.

Thank you.


Some features of ATS will be disabled while you continue to use an ad-blocker.


Monoprice Tablet Won't Work Properly

page: 1

log in


posted on Dec, 21 2016 @ 11:28 AM
Hello ATS, I've returned from the bowels of my deep dark cave to ask a question. I have a new laptop, an Acer with 8GB of memory and about a thousand GB of hard drive space. This laptop is great. It runs Fallout 4 and everything.

But ever since i downloaded Paint Tool Sai and the drivers for my Monoprice drawing tablet, I haven't been able to draw. Each time I try to make a stroke, it gives me no lines or it randomly changes the colors that I'm using. I'm being very careful not to press the buttons on the side of the pen. I don't understand why it's acting so screwy. It's making it impossible for me to draw.

I've tried rebooting, uninstalling and reinstalling the drivers, and changing the settings in SAI. I've also tried using a different pen. Nothing works.

is it a conflict with Windows 10? Or is it something that can be fixed in the settings?

I don't know what to do.

posted on Dec, 21 2016 @ 11:42 AM
a reply to: XxNightAngelusxX

Sounds like you may have picked up a virus when downloading the drivers.

Download and Run the free version of

And the free version of

Make sure you use both of them, They do 2 different types of scans

In my experience anything that suddenly changes like that is due to a virus of some sort, Especially if you've just downloaded something.
edit on 21-12-2016 by ColaTesla because: (no reason given)

posted on Dec, 21 2016 @ 12:13 PM
Malwarebytes for sure.

Id say you have a driver issue, not uncommon.

Seems like everything works, but the tablet right?

I work in IT, and it sounds a lot like a corrupted driver. I deal with this everyday in Health IT, usually when a driver goes bad it will either stop completely, or start acting silly(random messages, intermittent responses, etc. Then again it could be that the driver is not compatible with Win 10.

I would uninstall the driver, reboot find the proper driver from the manufacturer and make sure it is compatible with Windows 10. Install it, reboot again just to get a fresh start and let us know how it turns out?

Good luck OP

posted on Dec, 21 2016 @ 12:34 PM
You can try These to see if it will work with your issue. Sai seems a bit wonky with tablets for some reason.

I had a similar issue with my wacom after updating my drivers. Turns out the most current drivers were the problem and had to revert. Once I did that it worked like before. Not sure if it would work for yours but it's worth a shot.

new topics

top topics

log in