It looks like you're using an Ad Blocker.

Please white-list or disable in your ad-blocking tool.

Thank you.


Some features of ATS will be disabled while you continue to use an ad-blocker.


Quotas on OpenVZ VPS issue

page: 1

log in


posted on Jan, 15 2015 @ 09:47 PM
Well I've already tried a few forums with no replies yet, might as well try here. . .

It's pretty straight forward. I'm on an OpenVZ VPS with OVH. Trying to get quotas enabled for my first time. It's a project with a good purpose. Got 26 users, need to limit them to 300MB space on the VPS a piece within their home directory.

So I try to follow this guide:


I can't get halfway through without running into an issue :/ Pretty sure it's just a simple limitation with OpenVZ, and I'll need to find some other way, but maybe not. Maybe I'm just ignorant, and someone can help me out here.

Quota was already installed, so I cd into /etc/fstab. I added this line:

LABEL=DOROOT / ext4 errors=remount-ro,usrquota 0 1

then went for:

mount -o remount /

however; permission denied was response. I'm guessing this is a hard limit... i'm root on the VPS, should have all access, except this is paravirtualization, openvz... so am I just scrooged here, or not going about this the correct way?

Other thought I had was to attempt to create 26 additional partitions, and only give access to 1 a pop each user, at 300MB per partition, but that seems kinda silly, and still not sure even possible on OpenVZ.

I need this done, ASAP. Got work to do on the web developing end, and start school next Tuesday. I got this coming weekend to slam this out. Any help would be GREAT!!LY Appreciated.


PS if this went over your head, don't feel bad. Not many people know this kinda stuff... I'm still learning.

posted on Jan, 15 2015 @ 11:19 PM
a reply to: pl3bscheese

I followed that perfect server guide a while back, didn't get to mess with openVZ, but I think you just reignited my curiosity. I wish I could say I was doing it for school or work that awesome.

I found this, maybe it can point you in the right direction?

I wonder if you are running into a limitation because of memory or swap. I'm probably way off! I wish I could help. You sound like a smart dude or gal, you'll figure it out. Good luck!

ETA I was running that inside of ESXi. I had a lot of luck with learning things, using ESXi or some other virtualization.

edit on 15-1-2015 by sicksonezer0 because: (no reason given)

posted on Jan, 15 2015 @ 11:44 PM
a reply to: sicksonezer0

I've got ESXi 5.5 on the home rig, no limitations there as it's bare-metal full virtualization. OpenVZ is paravirtualiation. You're limited in some respects. Tried to get docker installed to run discourse forum software on OpenVZ where the host kernel was 2.6x. Not going to happen. Docker will require AUFS, and that's going to be 3.13x or better. So I know limitations exist with OpenVZ; however it can't be from the kernel version, as quota has been with us long before 2.6. It may be that quotas must be set outside the VM instance, so at the host level. Being that this is OVH, it's not managed like that... you can't request something of this nature.

So I'm basically waiting for someone (trying OVH directly as well, no response yet) to confirm this is a no-go, and I'll have to get clever and figure something else... am kinda at a stand-still until this is figured. Users must be limited one way or another. I can imagine a few ways it could work out in theory, but how I actually get there ... is something else.

howtoforge has provided me some decent guides... i'll check it out, thanks. oh the perfect server... that must be ISP3Config... yea I don't run control panels anymore. I do everything raw & manual. Too many issues with control panels bastardizing the file structure, and creating security holes... not worth it, imo. You figure it out the right way, and never have to learn it again. I'm okay with that.
edit on 15-1-2015 by pl3bscheese because: (no reason given)

posted on Jan, 15 2015 @ 11:47 PM
Your link results in a 404 - not found error


posted on Jan, 15 2015 @ 11:49 PM
a reply to: ogbert

Bleh, 4hr edit limit. Silly thing. Thanks!

Here is fixed link:


So if you check that guide, I decided to go through the rest, and skip the remount to see what would happen. It showed soft/hard limits were in place. I sftp with the user which limits were created for, uploaded files until quota should have been exceeded. Checking showed quota continued to be allowed to surpass limits. It didn't work. It seems the remount was a necessary step. Ideas?
edit on 15-1-2015 by pl3bscheese because: (no reason given)

posted on Jan, 16 2015 @ 12:20 AM
I am not really experienced with openVZ, but in the docs, it appears that you can set Quotas in the global config file.



shot in the dark

good luck
edit on 16-1-2015 by ogbert because: (no reason given)

posted on Jan, 16 2015 @ 07:40 AM
a reply to: ogbert

Thanks, that solidified it for me. Disabled.

The parameter that controls the second-level disk quotas is QUOTAUGIDLIMIT in the Container configuration file. By default, the value of this parameter is zero and this corresponds to disabled per-user/group quotas.

It would appear second-level quotas are disabled. What you were seeing was host-level quotas to limit the size of the containers which have VPS instances. I've got 10GB allocated to me, but need to further sub-divide this into 300MB quotas at the user-level. Think I'm going with for their object storage.

posted on Jan, 16 2015 @ 06:59 PM
glad you got it figured out.

Now if only I can figure out how to get an 89 Lincoln to start that is getting gas and fire, but will not crank working- we will both be moving

posted on Jun, 11 2015 @ 08:43 PM
Wow have I come a long way since this thread. This is for the off chance someone is using OpenVZ VPS having issues, and stumbles onto this thread. OpenVZ has serious limitations. You're will (mostly likely) be given an:

- oversold instance
- incapable of making swapfile
- incapable of creating quotas
- GL with docker apps needing aufs

IME ovh seriously oversells, and openvz will cause you more suffering in the long run, and should never be used for production gigs. Don't cheap out, get halfway through a project, and realize it's not going to happen, or open shop and get pwned to the security vulnerabilities inherent in openvz architecture.

new topics

top topics


log in