Help ATS with a contribution via PayPal:
learn more

Wireless Router Question: XP can't connect with WPA password.

page: 1
0
<<   2 >>

log in

join

posted on Feb, 12 2013 @ 08:11 PM
link   
Recently I was ousted in a palace coup from my position as network administrator where I live.

The new administrator has replaced my old MAC Address Filter sytem of security with a WPA password system of protection. I'm told by others that the system works and that they are able to connect to our router with no problem.

For some reason I am not able to connect.

I am running XP Pro SP2 on my laptop and have downloaded from Microsoft a fix that is supposed to enable the OS to negotiate a WPA password arrangement. However I still cannot connect.

I am wondering if there is some configuration issue that I am unaware of that is preventing me from getting through. All help appreciated.




posted on Feb, 12 2013 @ 08:15 PM
link   
reply to post by ipsedixit
 


Did you just use MAC address filtering and security in the same sentence? haha

But seriously, have you tried any other devices to connect? Is the wireless network using the same name? Your PC could be holding onto old connection info. Try creating a new user account on your machine and see if that works.



posted on Feb, 12 2013 @ 08:16 PM
link   
I recently did a similar upgrade at my end.

Just removed all saved wepkeys, I reinstalled the new WPA settings on my old xp and worked flawelessly.

This article should help. compnetworking.about.com...

Peace



posted on Feb, 12 2013 @ 08:17 PM
link   
reply to post by AnonymousCitizen
 

I'll try a new user account.

(I'm considered an old fogey now and am being pushed aside roughly by the younger bodhisattvas.)



posted on Feb, 12 2013 @ 08:19 PM
link   
reply to post by ipsedixit
 

You will need this fix to enable WPA2 which is what I assume you are referring to even though you said WPA. WPA2 is pretty much de facto nowadays. If the update from MS doesn't help then you probably need updated drivers for you WLAN card. Good luck.


ETA: This MS patch enables WPA support. Hope it helps.
edit on 12/2/13 by LightSpeedDriver because: ETA



posted on Feb, 12 2013 @ 08:23 PM
link   
GO TO C-NET .com lots of hacks for that or open garden .com??



posted on Feb, 12 2013 @ 08:33 PM
link   

Originally posted by ipsedixit
reply to post by AnonymousCitizen
 

I'll try a new user account.

(I'm considered an old fogey now and am being pushed aside roughly by the younger bodhisattvas.)



Do you have reason to believe that the youngsters actually want you to not be able to connect? They may know more tricks than an old fogey....



posted on Feb, 12 2013 @ 08:37 PM
link   
In your wireless profile, uncheck the 802.11 authentication, and it will connect. This was a small glitch with XP.
edit on 2/12/2013 by Klassified because: eta



posted on Feb, 12 2013 @ 08:53 PM
link   

Originally posted by Klassified
In your wireless profile, uncheck the 802.11 authentication, and it will connect. This was a small glitch with XP.
edit on 2/12/2013 by Klassified because: eta


It is unchecked. Weirdly, when I try to enter the new WPA password into the profile it is accepted but, the computer coughs up the old password when the prompt to confirm password on connecting comes up. I just type in the new password, confirm it and wait, but the connection to the internet is never made.

The USB device sees the router but I can't get the router to accept the password.



posted on Feb, 12 2013 @ 08:57 PM
link   
reply to post by LightSpeedDriver
 

I have the patches installed. Restarted my computer but still no results. Thanks but I think it must be some configuration issue in XP.



posted on Feb, 12 2013 @ 09:00 PM
link   
reply to post by ipsedixit
 

All old profiles with the same SSID must be deleted. Then create a new one from scratch.


ETA: It doesn't hurt to restart the computer, and cycle the router after deleting the old profiles. It sounds redundant, but it sometimes helps.
edit on 2/12/2013 by Klassified because: eta



posted on Feb, 12 2013 @ 09:10 PM
link   
reply to post by Klassified
 

OK. I'll try that. Another strange thing was that I downloaded the driver for the wireless USB connector that I use for the laptop and installed them on my desktop running Windows 7 (Home) and it wouldn't connect either.

According to the specs on the wireless unit, it is compatible with WPA2, so I am really surprised that I still couldn't connect from the desktop.

Everyone running Mac tablets or Android based tablets is connecting with no problem.

edit on 12-2-2013 by ipsedixit because: (no reason given)



posted on Feb, 12 2013 @ 09:22 PM
link   
I had to research this problem recently, some wireless cards released in XP laptops cannot read the WPA2 encryption format. Even with updated drivers. I didn't read the entirety of the thread so I'm not sure if you mentioned this, but if it's an internal card, try purchasing a usb wireless adapter. The problem will resolve itself instantly if this is the problem. For later user clarification, disable the computers standard wireless hardware, and then run the new adapter through windows (avoid using provided third party programs because they eat up you memory).



posted on Feb, 12 2013 @ 09:49 PM
link   
reply to post by wishful1gnorance
 

Unfortunately I still can't connect in spite of using an external USB wireless connector. I'm on a laptop running XP Pro SP2, but even on a desktop running 7, I couldn't connect with the same wireless unit.

Prior to the switch to a WPA2 based password, I had no trouble connecting. This has to be some configuration issue.



posted on Feb, 12 2013 @ 09:57 PM
link   
reply to post by ipsedixit
 

The new WPA system...is that on new hardware or the same hardware (Access Point, Wireless Router, whatever) you used to connect to?
ETA I'm thinking range or radio power problems. Not all Wifi cards, devices, mobile phones, etc are the same. I've had the same problem here, one device can connect fine while another struggles to build up a connection. Most new mobile phones I've seen have better range than my Wifi G and N card.
edit on 12/2/13 by LightSpeedDriver because: ETA



posted on Feb, 12 2013 @ 10:13 PM
link   

Originally posted by ipsedixit
reply to post by wishful1gnorance
 

Unfortunately I still can't connect in spite of using an external USB wireless connector. I'm on a laptop running XP Pro SP2, but even on a desktop running 7, I couldn't connect with the same wireless unit.

Prior to the switch to a WPA2 based password, I had no trouble connecting. This has to be some configuration issue.



Apparently you didn't take my earlier question seriously. But I'll offer a possible solution anyway.

Since you were replaced by forcible coup, my thought would be that the youngsters killed your wi-fi connection by "arp poisoning." I won't get into what that means here, but if that's the case, you can get around it by using a "static" IP-to-MAC arp mapping. I sometimes use this to solve intermittent or unknown network problems.

The first thing you need to know is that when setting up a router you usually set aside a range of DHCP IP addresses that will be assigned dynamically. All IP addresses outside that range can be assigned statically. For instance, all the addresses in the range 192.168.1.10 to 192.168.1.200 are DHCP. Anything outside that range can be taken as static addresses. (Sometimes, depending on how you set it up, the DHCP addresses can also be used statically.) If you happen to know what range has been set to DHCP, pick an IP address outside that for your own use. Otherwise, just pick one at random and try it.

Now, as you probably know, every network device has a burned-in permanent MAC (media access control) address. Network connections are actually made through the MAC. By using arp, you can permanently assign an IP address that maps to the MAC address of your network device.

You probably know this, but some people reading this may not: You can find the MAC address of your network device with the command (at the command prompt):

ipconfig/all

Read the resulting screen output. You can't miss it.

Now all you need to do is use arp to map your chosen IP address to your MAC address thusly:

arp -s ipaddr macaddr

As a random example, let's say you want to use the IP address 192.168.1.224 and your MAC address is 00:50:BA:85:85:CA. Use the command:

arp -s 192.168.1.224 00-50-BA-85-85-CA

Keep in mind that this mapping is only good during the current "session" (that is, until you restart your computer). You can, however, put it in a .bat or .vbs file and run it at startup.

OK....


edit on 2/12/2013 by Ex_CT2 because: (no reason given)



posted on Feb, 13 2013 @ 02:15 AM
link   
reply to post by LightSpeedDriver
 

It is all the same hardware. One day I was able to connect going through the MAC address filtering system. The next day, when the new guy switched it to a WPA password, I was not able to connect, but others in the house could connect.



posted on Feb, 13 2013 @ 02:19 AM
link   
reply to post by Ex_CT2
 

I stalked off in a huff. I was like what Hitler said of Russia, "All we have to do is kick in the door and the whole ramshackle edifice will crumble."

Except Russia and I, though shocked at first, haven't actually crumbled.

Thanks for the instructions. I will give them a try tomorrow some time. For now I have to get some other things done.



posted on Feb, 13 2013 @ 03:27 AM
link   

Originally posted by LightSpeedDriver
reply to post by ipsedixit
 

You will need this fix to enable WPA2 which is what I assume you are referring to even though you said WPA. WPA2 is pretty much de facto nowadays. If the update from MS doesn't help then you probably need updated drivers for you WLAN card. Good luck.


ETA: This MS patch enables WPA support. Hope it helps.
edit on 12/2/13 by LightSpeedDriver because: ETA


Yep, that'll do it. Most XP NIC's dont have the higher end security enabled. need to add the patch!
Worked for me on many a clients pc.



posted on Feb, 13 2013 @ 03:46 AM
link   

Originally posted by Ex_CT2
Now all you need to do is use arp to map your chosen IP address to your MAC address thusly:

arp -s ipaddr macaddr

As a random example, let's say you want to use the IP address 192.168.1.224 and your MAC address is 00:50:BA:85:85:CA. Use the command:

arp -s 192.168.1.224 00-50-BA-85-85-CA


I went to the command line, to C:\ and typed the command suggested (using appropriate numbers). cmd.exe did not object to the command, but after that I wasn't sure what to do. Does the wireless unit connect automatically? If that is supposed to be what happens, it did not in fact happen.






top topics



 
0
<<   2 >>

log in

join