Annoying Firefox Problem

page: 1
0
<<   2 >>

log in

join

posted on Nov, 17 2012 @ 10:12 AM
link   
Since about 2 or 3 updates ago,

When I "Open link in new window",

The new window will open for a second, and immediately hide behind the originating _


Seems to be linked to the "Shockwave" extension, because when I disable it, the problem goes away.

But then I can't watch Shockwave videos!

Everything seems to be up to date, and my complaints to both Firefox and Adobe seem to fall on deaf "eyes?"


"New Tabs" work fine, But I hate using Tabs...


Maybe I should have posted this in the rant section..




posted on Nov, 17 2012 @ 10:16 AM
link   
reply to post by IrVulture
 


Why would you hate using tabs? Much more organized than a dozen windows sitting at the bottom...



posted on Nov, 17 2012 @ 10:16 AM
link   
I am having the same problem, when i open a new tab it just hangs for a minute. It is annoying.



posted on Nov, 17 2012 @ 10:21 AM
link   
Firefox has become less stable as the versions have increased i've found. So much so that i've made the switch to Chrome. I'm not too keen on using it, but it is a lot more responsive and stable than Firefox.

Might be worth checking out to see if it fixes your problem.



posted on Nov, 17 2012 @ 10:24 AM
link   
Just use Chrome ... Always fast, Always working, Never problematic!

Firefox in my eyes is only slightly better than IE!



posted on Nov, 17 2012 @ 10:27 AM
link   
haha the multitude of problems I have with avg and firefox have given me the opportunity to learn so much more about computers.

seriously though lol its terrible and sometimes you just have to read hours of forums until you figure it out and then force yourself to look at the experience positively

you could always uninstall and reinstall and see if that helps



posted on Nov, 17 2012 @ 10:58 AM
link   
If you are using W7 - 64 bit... check out Waterfox Browser


I've been using for a couple of weeks now, it's just like FF, but built
for 64 bit systems. I actually have noticed a little better performance / speed.


Might help with your problem ?



posted on Nov, 17 2012 @ 11:04 AM
link   
I don't know why these companies never learns the lesson of updating too often: You end up with unstable releases and unhappy customers.

You might try going to their site and downloading an earlier release you were happy with. Turn off (or don't install) the automatic update feature. Once you find a release you like, leave the installation file in a handy place so that you can go back to it if you have problems. After a few months, if you feel like updating, then do so....



posted on Nov, 17 2012 @ 11:18 AM
link   
I'm using firefox on linux with no problems, although I must admit I'm a big one for using tabs.

As far as using Chrome goes - I eliminated all of that NSA code from my system when I dumped windows.

ganjoa



posted on Nov, 17 2012 @ 11:21 AM
link   
reply to post by ganjoa
 


I currently have five tabs open. That's just one _ The other window has three tabs open. I'm a tab lover. Much more convenient.



posted on Nov, 17 2012 @ 11:28 AM
link   
reply to post by AfterInfinity
 


I also use a lot of tabs.... usually 2 browser windows open with multiple tabs on each.



posted on Nov, 17 2012 @ 12:05 PM
link   

Originally posted by elevatedone
If you are using W7 - 64 bit... check out Waterfox Browser


I've been using for a couple of weeks now, it's just like FF, but built
for 64 bit systems. I actually have noticed a little better performance / speed.


Might help with your problem ?


I've just downloaded Waterfox, and installed it, and i don't see any difference



posted on Nov, 17 2012 @ 12:08 PM
link   
reply to post by elevatedone
 


Four windows with about eight tabs on each, give or take a couple. If I only have one window open, you can bet there's at least 23 tabs open...several of which I'm not even using.
edit on 17-11-2012 by AfterInfinity because: (no reason given)



posted on Nov, 17 2012 @ 01:03 PM
link   
reply to post by IrVulture
 

What type of computer do yo have? Your OS, ram, swap, etc?


You can try running FF in safe mode:

For windows:
Start > Run
Firefox –safe-mode
Then click ``Disable all add-ons``

See if it runs smother, if it does let me know.
edit on 17-11-2012 by Rockdisjoint because: (no reason given)



posted on Nov, 17 2012 @ 05:48 PM
link   
reply to post by Rockdisjoint
 


I'm running 64bit Windoze Vista, 8Gig of RAM...

The reason I hate tabs so much?
I'm so used to opening new windows, I usually end up closing all tabs and have to start all over again.



posted on Nov, 18 2012 @ 10:22 AM
link   

Originally posted by IrVulture
The reason I hate tabs so much?
I'm so used to opening new windows, I usually end up closing all tabs and have to start all over again.


FF used to save all tabs and re-open them, until they updated to version 4. Dy default it is now disabled, but you can change that easily.


Go Here to see how to enable it.

Hope that helps you. It was a major pain in the you know what when I upgraded to version 4.



posted on Nov, 18 2012 @ 06:10 PM
link   

Originally posted by faryjay
Just use Chrome ... Always fast, Always working, Never problematic!

Or use SRWare's Iron, it uses the same base as Google and doesn't have all the "extras" Google added to get information about the users.


PS: I prefer Opera.
edit on 18/11/2012 by ArMaP because: (no reason given)



posted on Dec, 31 2012 @ 12:15 PM
link   
Fixed it!

Wasn't a Firefox problem after all, but a Windows setting buried deep within the control panel...

Appearance > Folder Options > View>>> Check the box marked "Open window in new process"


Thanks for everyone's help... or not.



But anyways, HAPPY NEW YEAR!!!!



posted on Dec, 31 2012 @ 02:13 PM
link   
reply to post by IrVulture
 


Thanks for sharing the solution.


Happy new year!



posted on Feb, 10 2013 @ 02:57 PM
link   

Originally posted by IrVulture
Fixed it!

Wasn't a Firefox problem after all, but a Windows setting buried deep within the control panel...

Appearance > Folder Options > View>>> Check the box marked "Open window in new process"


Thanks for everyone's help... or not.



But anyways, HAPPY NEW YEAR!!!!


Whoops!

That wasn't it either, But I did FINALLY figure out what the problem was......

"The wireless mouse driver"

Seems the mouse driver was also causing my computer to shut down (in an orderly fashion) on occasion,
and the event log was posting error after error until it hit a critical point....

Cheapo "Big Lots" wireless keyboard and mouse set worked great for over a year till something corrupted the driver for it (Microsoft updates?)

Anywho, Replaced said mouse with a Logitech wireless trackball and all is well now....





new topics

top topics



 
0
<<   2 >>

log in

join