It looks like you're using an Ad Blocker.

Please white-list or disable AboveTopSecret.com in your ad-blocking tool.

Thank you.

 

Some features of ATS will be disabled while you continue to use an ad-blocker.

 

Problem installing Virtual Box on Linux

page: 1
0

log in

join
share:

posted on Sep, 2 2011 @ 10:28 PM
link   
I recently installed a 32 bit Unity-Linux distribution called Humanity 2011. It's based on Mandriva and uses the RPM packaging. I'm using the Enlightenment Desktop, and trying to run Windows XP in Virtual Box, because Wine won't run some of my favorite Windows Apps. I've installed Bochs Emulator as well and it doesn't show up in my menu, so I'm not sure what to do with that, although I haven't tried to run it from a terminal yet.
Here's the problem; I've installed all the software to run Virtual Box, but it says I need vboxdrv. Unfortunately it doesn't show up in my Smart Package Manager. I did a search online and found a site called pkgs.org, but they don't have the driver for my kernel which is 2.6.35.8. Any suggestions?

I'm not completely new to Linux, but close. I bought a Mandrake distro back in 1999, but I never got to install it, and I ran Ubuntu for a short time a few years back. I really like the Enlightenment Desktop, which in my distribution comes with Ecomorph, but I haven't played with it yet. I'm still setting things up. I tried to install OpenGEU before I found Unity, but hardware gave me problems. There's a video of OpenGEU using Ecomorph if you haven't seen it in action. It's pretty awesome...





posted on Sep, 2 2011 @ 10:57 PM
link   
Here's a screenshot of my Enlightenment Desktop. I'm running Humanity 2011, a Unity-Linux homebrew I found at a Wordpress blog. Enlightenment truly is a beautiful desktop...
I added the wallpaper which can be found at:

wallpaper




posted on Sep, 2 2011 @ 11:14 PM
link   
Hmm I've never had that error before. Maybe the package isn't compatible with your distro. There is one listed under downloads in the Linux section as All Distributions i386 download.virtualbox.org... and AMD64 download.virtualbox.org...

If that doesn't work you can try VMware Player it's free but you have to register it by e-mail www.vmware.com...



posted on Sep, 2 2011 @ 11:39 PM
link   
reply to post by IlluminatusOculus33
 

Thanks, I just installed the Virtual Box today, and the dialog box said install dkms and vboxdrv. I installed dkms, but didn't realize until just now that there is a program called dkms-virtualbox. After installing that it works fine. The link you show is an update for the app that isn't on my repository just yet, so thanks for the heads up on that.
I'll probably continue to have problems with Linux for awhile, but I think it's definitely worth the trouble. At 51 years of age, I still get intimidated by new things but I try not to let it stop me from making improvements. Linux is definitely an improvement...



posted on Sep, 4 2011 @ 10:37 AM
link   
I don't see how Linux is an improvement. It's kind of a hassle at times, there are bug regressions and bugs in general which can make it a pain to use.

Windows is easier to use and has the most support when it comes to hardware. Those reasons alone are why it's the most successful operating system.

Windows is also standardized so if you know how to install it on one system you can install it on all systems. The GUI is of one type and the software installation is standard. When it comes to Linux you have different system installs, different GUIs, different package management, etc. It's a bit of a mess. It won't ever dominate the desktop because it's too diverse and not standardized. Most people would buy a Mac instead of using Linux if they wanted to get away from Windows, again because it's standardized with installation and GUI.



posted on Sep, 4 2011 @ 08:54 PM
link   
I know what you mean. This distro has given me nothing but problems. The desktop keeps crashing, so I thought I would try another distro. I had to dig a little but I found a PcLinuxOs distro that had the enlightenment desktop as well. While it was installing, it said "Warning, you need to install XDM. Do you want to download it now?" So I clicked yes, and it said "There was an error downloading XDM." After that it wouldn't let me log on, so I tried to re-install it. It wouldn't load the live-cd anymore.

I tried Bodhi, and it wouldn't load the cd. At the moment, I'm writing Elive Topaz to a disk to try it. If it doesn't work, I'm done.



posted on Sep, 4 2011 @ 09:36 PM
link   
reply to post by visualmiscreant
 


Best of luck, hope you can get one of them to work.



posted on Sep, 5 2011 @ 01:53 AM
link   
reply to post by IlluminatusOculus33
 


Wouldn't you know it; elive wouldn't work either. My wife likes to call me relentless, so I had to live up to it, and reinstalled the Humanity/Unity home-brew (at least it would install). I found that by logging into E-17 instead of Enlightenment that everything works fine. I'm not really sure why, but I think E-17 is the newer of the two, and the original didn't get deleted from the menu.

I dumped the idea of running Windows in Virtual Box because it takes too long on my computer. I decided instead to repartition the drive for both file systems, and install both Linux and Xp on my master drive. My slave has my main Xp setup on it, and I'll use it for storage, etc., keeping it for backup just in case.

I'm gonna give it a shot for awhile. and who knows; I may learn something! There are a few things I don't care about with Linux. The main thing being that they recommend that you update your packages weekly (or at least every two weeks) to prevent "breakages". This makes you depend on an internet connection to keep your system from having problems. I don't plan on losing my connection any time soon, but it's the principle. When I didn't have a connection, and even when I just had dial-up, I could go to the library to download new apps for my Xp. That's not recommended for Linux, because they want you to use their repositories only. The reasoning is (they say), because the repositories constantly update their packages, and by downloading elsewhere you could corrupt your system integrity. This means you are also dependent on the repositories. That's two dependencies you don't have with Xp.

My concern is that because of Xp's age, Microsoft will stop supporting it soon, and I'll have to change systems anyway. They've already stopped supporting 95 and 98. Xp is not much younger than 98.
Anyway, thanks again for the advice...



posted on Sep, 5 2011 @ 07:44 AM
link   
Windows XP will be supported till 2014 by Microsoft, making it being around for a total 13 years when support ends for it. That's the longest supported version of Windows lol. You still got a few years left.



posted on Sep, 7 2011 @ 10:25 PM
link   
reply to post by IlluminatusOculus33
 

That's cool, thanks. Right now you-tube isn't working on my Windows drive. I just installed it the other day and the adobe flash player plugin was already version 10.something. I can't find a way to fix it, but a lot of people are having the same problem after upgrading the flash plugin. I've tried every one of the solutions offered on the forums, and none of them work for me. My Linux drive is working fine, so I have to watch videos with it. Maybe sometimes it's good to have two systems...

I still have my other hard drive with Windows on it, and the flash plugin hasn't been upgraded yet. I haven't checked it out though. I'm fine for now...



posted on Sep, 7 2011 @ 10:31 PM
link   
You can download the newest version here of Flash 10.3.183.7 get.adobe.com...

Also if you have cookies blocked on YouTube you will get player errors where the box is black with some kind of error text. If that's the case enable cookies for YouTube and it will play videos.



posted on Sep, 8 2011 @ 02:46 PM
link   
My God what a problem the Youtube thing was, but I finally got it fixed. It turns out I was missing the file "dsound.dll in my system files. Like I said, I just installed this copy of Windows the other day, and some of the updates probably haven't run yet. After downloading a copy and extracting it into my system32 directory, the problem was solved, just like that. Thanks for the help...



posted on Sep, 8 2011 @ 02:58 PM
link   
Glad you got the problem fixed.

Also if you're really desperate to run Linux you can always try PCLinuxOS www.pclinuxos.com... things tend to work better out of the box on hardware support.
edit on 8-9-2011 by IlluminatusOculus33 because: (no reason given)



new topics

top topics



 
0

log in

join