Help ATS with a contribution via PayPal:
learn more

Back right brake light wont work. Nissan X terra.

page: 1
0

log in

join

posted on May, 20 2011 @ 03:04 PM
link   
Hey guys I have a Nissan Xterra 2004 (bought it used) anyways. I figured it was the bulb and of course with my luck it wasnt the bulb after i changed it. then I figured it might be the fuse but there is only one fuse that controls all the brake lights (from what I see) and the other ones work. My next guess would be the thing that the light goes in is bad. not sure what to do there.

anyone have any other ideas?
edit on 20-5-2011 by mayabong because: (no reason given)




posted on May, 20 2011 @ 03:08 PM
link   
Do other lights work? If not , check all relays.

If so, use voltimeter on power lead from bulb socket.

If so, and no power to socket shown on voltimeter, check socket for disconnected wire and trace wire and visually inspect for shorts .

Good luck.
edit on 20-5-2011 by sixswornsermon because: ..



posted on May, 20 2011 @ 03:13 PM
link   
In most cases it's as simple as a loose connection either at the light plug(what the light is plugged directly into) or at the other end of the connection. These wires can be jarred loose if you off-road. It happens to my S-10 all the time.



posted on May, 20 2011 @ 03:15 PM
link   
reply to post by KnightwhosaysNi
 


True. I have had starter relays pop out after particularly nasty hits while off road.

There's not much that it can be. Especially if other lights on the same fuse are working.



posted on May, 20 2011 @ 03:20 PM
link   
Cool I'll go check some of these things. Thanks guys



posted on May, 20 2011 @ 03:52 PM
link   
Ok success (kinda). It seems the bulb holder is just wonky and the connectors are corroded (I guess) bulb seems to work when I pull it out a little but doesn't when fully inserted. Any way to clean of corrosion besides coca cola? lol



posted on May, 20 2011 @ 04:00 PM
link   
reply to post by mayabong
 


Try a can of electrical contact cleaner, and a fine wire brush for what corrosion you can get to. Hose it down good with the contact cleaner. It will dry quickly.

If not, try Nissan parts department for the replacement fixture, then cut off old fixture, then solder new on to existing wires.
edit on 20-5-2011 by sixswornsermon because: sp



posted on May, 20 2011 @ 04:09 PM
link   
Sometimes you won't have to solder anything. In many cases, like with electrical socket plugs, the wires are screwed onto contact plates. If there is any corrosion, save yourself the money and soak the wires(after removing them of course) in baking soda and water. Works wonders on corroded battery cables too.



posted on May, 20 2011 @ 11:59 PM
link   
thanks guys you really saved me a headache! Really!



posted on May, 21 2011 @ 09:53 AM
link   
If you have an emory board, that can be trimmed down and works well to clean contacts allowing you to get in between the two contacts.

The tail light lenses have a rubber gasket around them to keep moisture out and commonly lead to this problem.
Make sure the lense is dry inside and clean out any moisture that might have accumulated inside.
Once you have cleaned the contacts, you can spray a little Lithium Grease on them to keep moisture out.
Test the bulb before sealing everything up.

And finally make sure the lens is snug and the gasket is sealing correctly keeping all moisture out.

Coca Cola is not for electrical connections. It would only dry and the sugar creating an insulator to the electrical current and even more problems.



posted on May, 22 2011 @ 09:19 PM
link   
reply to post by mayabong
 


Glad it worked out man!



posted on Jul, 17 2011 @ 02:34 AM
link   
reply to post by mayabong
 


edit on 17-7-2011 by granpabobby because: (no reason given)





new topics

top topics



 
0

log in

join