It looks like you're using an Ad Blocker.

Please white-list or disable AboveTopSecret.com in your ad-blocking tool.

Thank you.

 

Some features of ATS will be disabled while you continue to use an ad-blocker.

 

Star Wars Episode I: Pod Racer

page: 1
0

log in

join
share:

posted on Aug, 7 2005 @ 01:57 AM
link   
I just got this game for my computer today. I've played it numerous times on the N64, and found it to be really fun. Unfortunately, on the computer, I cannot figure out how to engage the 'boost' mode on the pods. I customized the keyboard settings, so it's not because I'm pressing the wrong button. I'm probably doing something wrong in the timing.

On the N64, I had no problems going into 'boost' mode. You just had to go to top speed, then push the right button, and BAM! You were going at like 800mph.

Someone help me.....
I want to go faster!

[edit on 7-8-2005 by DragonsDemesne]




posted on Aug, 15 2005 @ 04:07 AM
link   
I always used to press 'enter' though i may have reconfigured it.

Having said that just go into the options screen and look up the controls.

The only real way to play Podracer was in the arcade cabinets with the cockpit from the film though, much more fun!



posted on Aug, 17 2005 @ 03:32 AM
link   
Lol, I did try going into the options screen, already. That was the first thing I thought of, that I was pushing the wrong button. But no matter what I configure it to, it doesn't work. I'm thinking there is something else missing. Maybe I have to buy a particular part at the junkyard (though I never had to do that on the nintendo, I could go turbo in the first race) or maybe the timing is different than on the N64.



posted on Aug, 17 2005 @ 03:55 AM
link   
Woohoo, a buddy of mine just explained it to me. On the PC, you have to also use pitch at the same time you are accelerating, then press the boost button. On the 64, you didn't have to use the pitch. That's why I was never boosting!



new topics

top topics
 
0

log in

join