It looks like you're using an Ad Blocker.

Please white-list or disable AboveTopSecret.com in your ad-blocking tool.

Thank you.

 

Some features of ATS will be disabled while you continue to use an ad-blocker.

 

Civil 3d 2018

page: 1
2

log in

join
share:

posted on Feb, 7 2018 @ 08:27 AM
link   
I was wondering if any members here use Civil 3d 2018?
I am starting to have performance issues with it.

Previously I would be able to create a feature line, weed it, and create a grading on it in less than a minute.

Now i dread even having to use feature lines.
For some reason they are taking hours to complete now.
I have an 81 meter feature line. I selected weeding, it said it could weed 6 nodes. Those 6 nodes took Civil 3d over an hour to weed.
Now I am grading the feature line a total of 2 meters down to a specific elevation and its just sitting there taking its sweet time.

It took the better part of the entire day yesterday to grade about 1 km of feature lines.
Im ready to pull my hair out here.

Any suggestions, or has anyone else experienced this?
Like I said, it would steam through this process in less than a minute.
Now it takes hours for a small section.




posted on Feb, 7 2018 @ 10:21 AM
link   
a reply to: Macenroe82
C3D2013...are you creating a TIN from contours?



posted on Feb, 7 2018 @ 10:45 AM
link   
a reply to: Macenroe82

You might compare your system specs with the requirements.

Requirements are subject to change based on software updates and much of the time, companies don't bother listing updated specs. If they were honest about that sorta thing, much of the time, patches tend to require more and more resources from your system.

System Requirements

If you're very close to the threshold of the system requirements, it could be the issue. Requirements are lower than system recommendations. Requirements are minimal specs needed for no loss of performance but there are other factors that could cause issues.

- Hard drive fragmentation
- Hard drive space
- Temp files
- Active software or processes running in the background will always pull away from available resources.

etc etc etc


Of course I'm explaining this like you don't already know. I deal with a lot of people that don't so if you do.. It's just habit and likely already obvious to you. If it is... take it with a grain of salt. In the end, it's the thought that counts






edit on 7-2-2018 by StallionDuck because: (no reason given)



posted on Feb, 7 2018 @ 12:32 PM
link   
a reply to: manuelram16

Not yet,
Im grading from contours down to a surface. Once its graded I combine the grading with the rest of corridor to make a surface.



posted on Feb, 7 2018 @ 12:37 PM
link   
a reply to: StallionDuck

Thanks for the reply!

I am well beyond the required system specs.
I create 3d models using my photogrammetry software- Pix4d, with out any issue.

Its just when im using civil 3d and this only happens with feature lines im noticing.

Im thinking I might do a defrag over night, and if that doesnt work, a clean install in the morning.



posted on Feb, 7 2018 @ 12:51 PM
link   
a reply to: Macenroe82

No problem. I was using similar tools in college (3D animation), the reason I walked into the OP. I assumed you had it under control but I don't know adam from eve on here


Reinstalling is a good idea. I've had to do that before with some of the Art/Image software I use (Paint Stop Pro). Though the only time I've had to was due to upgrades from one major version to the other so now as a basic rule of thumb, If any software I use requires any decent sized update, it's time to uninstall/reinstall but updates suck in the first place. They tend to break more than they fix.

Not sure if you had to deal with any software updates and I'm not sure how long you've been using this proggie but they do tend to get rusty over time. I'm sure you'll figure it out. Something had to change from the time it worked well to the time it stopped working well. Figuring out what... That's the fun part.

If you can point to a specific date it started flaking, maybe look through event viewer in case there was an Operating system update, 3rd party update (video) or other.



posted on Feb, 7 2018 @ 01:07 PM
link   
a reply to: Macenroe82

I think StallionDuck posts an important. Updates can have huge changes in how the software processes things. A single procedural process may now have been changed to a multiple iteration ray-traced scene, to use an extreme example. I have no experience with the program in question, just to be clear.

Have you also checked Task Manager (with admin rights) that it is only civil3d consuming all the processor time? I know, it's a long shot. In my experience, defragging leads only to marginal improvements in overall speed. I hope you find an answer soon.



posted on Feb, 7 2018 @ 01:16 PM
link   
a reply to: Macenroe82

...Microstation Inroads master race here, but I also use Civ 3D, so I can relate.

This is the equivalent of asking if someone has tried restarting their machine, but are you missing any .shx or .shp enablers in your base file or Xrefs? Did you try turning off the preview selection before selecting the feature? Did you try importing only that feature into a clean file and trying it that way? Do you have a foreign/outdated dingleberry in your working file? (meaning were the files you're using worked in with an earlier version of Civ 3D, Map 3D, or non-Autodesk software?)

This is why I use dual platforms. There are things Inroads is far better at and things Civ 3D is better at. If I'm working with individual features and don't need a linked smart DWG file for BIM purposes, I usually find myself working it out using Inroads.

ETA: My office is still using AC 2014 because that's as up to date as our client base has gotten, so I'm sort of spitballing here. I do know the above listed issues are problems I've seen in 2014 and earlier over the years.
edit on 7-2-2018 by burdman30ott6 because: (no reason given)



posted on Feb, 7 2018 @ 01:31 PM
link   
a reply to: StallionDuck

I was almost certain you figured it out.
But when I checked to see if there was any pending updates there was nothing there. So I went to the autodesk website and checked the latest version of C3D an im on it.

Also i posted in autodesks forum this morning asking if anyone had experienced this before and apparently its a very common issue.
Basically I have to go through each drawing turn of graphic accelerator and run audits, then purge any crap that I dont need.
Save and close, reopen.
Sounds stupidly simple.
I had my doubts but for some reason it worked.

Its like night and day now.
Literally 2 freaken hours for a feature line to grade less than 100 meters.
Now its doing that in a snap!

Thank you very much to all that replied.



posted on Feb, 7 2018 @ 01:55 PM
link   
a reply to: Macenroe82

And thank you for posting back with also the silly steps needed to fix the problem. It's clearly a software bug but a funny one nonetheless and hopefully other readers may be helped by your post.


Software is what makes PC's weird because of the bugs.

It's just a jump to the left.
And then a step to the right.
With your hand on your hips.
You bring your knees in tight.



posted on Feb, 7 2018 @ 02:05 PM
link   
a reply to: LightSpeedDriver

hahah exactly.



posted on Feb, 7 2018 @ 03:57 PM
link   
a reply to: Macenroe82

While I don't have a fix for your problem, I believe the best thing that can happen here is for Autodesk to take a year out from releasing "improvements" and concentrate on releasing a stable software.

They've been doing this crap for years now and I'm over it.



posted on Feb, 7 2018 @ 08:36 PM
link   
a reply to: myselfaswell

Oh I know.
Like I get wanting to make billions of dollars off people.
But man, every year they release pretty much the same dang thing, just that the buttons have been changed to ribbons or vice versa and everything your comfortable with and finally know we're it's located gets hidden again.
To actually use everything and know how to use it and where it's hidden, you need to go to school for a year memorizing the locations of everything.
It's just silly.
You can only polish a turd so much.

But ya, I totally agree.
Take a freaking break from pumping crap out and fix the previous 10 years of software so they run as intended to.




top topics



 
2

log in

join