It looks like you're using an Ad Blocker.

Please white-list or disable in your ad-blocking tool.

Thank you.


Some features of ATS will be disabled while you continue to use an ad-blocker.


My snapmaker finally arrived and I can't make it work

page: 2
<< 1   >>

log in


posted on Jan, 17 2018 @ 03:45 PM

originally posted by: Hewhowaits
Hey guys,
I'm trying to figure out what I'm doing wrong here.

Your windows xp is too old.

You can't use this new device with your old operating system.

posted on Jan, 17 2018 @ 03:47 PM
And another...

Re: CH340-USB/RS232 Driver

Great news! I bought one of those a couple of years ago, and couldn't ever get it to work. So........

F/S - Chinese USB to RS 232 converter $5.00 + mailing (no PP chg.). Use the driver in the link below.

Re: CH340-USB/RS232 Driver

Wanted to simply get this shared out after getting this thing to work. I bought a USB2Relay controller using the same chipset above and found scatterings of information on it's use - so I figured I would locate a relevant and post example BASH code in case anyone else needed to get one of these USB Relays working... (The Mfg site is very sparse on code support)

I didn't see any "Code Block" controls for this forum - so forgive the lack of that...

Hope this helps others using this little Arduino 'compatible' Relay Controller knock off from China?

Re: CH340-USB/RS232 Driver

Hi! I had the same problem. I googled and found the solution here...


Step By Step Installation of CH340g Drivers

edit on 1.17.2018 by Murgatroid because: Felt like it...

posted on Jan, 17 2018 @ 04:03 PM
a reply to: AMPTAH

The driver is a confirmed working XP driver...

posted on Jan, 17 2018 @ 05:26 PM
I have all of these drivers installed.
Thanks to everyone who has tried to help.

I think what it really needs is some attitude adjustment -

via my .454
It's going up for sale in the morning, if I don't put 1500 grains of lead down its throat.

posted on Jan, 17 2018 @ 05:47 PM

originally posted by: Hewhowaits
I have all of these drivers installed.
Thanks to everyone who has tried to help.

I think what it really needs is some attitude adjustment -

via my .454
It's going up for sale in the morning, if I don't put 1500 grains of lead down its throat.

Don't give up. I would Reddit it. I'm certain someone can give you the information you need to get it going.

posted on Jan, 17 2018 @ 06:51 PM
I'm sure there is.

I'm just extremely frustrated at the lack of product development with these super smart tech people.

If I build a home to someone's specifications and blueprint, and they have a problem, I am there dping my dn best to make them happy. Not because I'm legally obligated to- but because it's the right thing to do.

I ordered a product and waited 6 months for it to show up and I can't use it..... No phone numbers to talk to customer service / support, no nothing...
And yes my computer is old, so friggin what? It's capable of doing simple things - and this is an x,y,z cnc machine that's supposedly self supporting.
It isnt, and won't do the basic functions of printing off the usb stick, like it's advertised..

I'm just pissed that now I have to fork out more cash.on another damn (newer) computer to run it.
I didn't want to sit around here and jerk off computers for two weeks trying to make my sh#t work.

Yes, I'm old.
Yes, I'm crabby.
You'll get there too.

But thanks for trying to keep me from shooting this damn thing. It is wonderful that all these members try to help when people like me encounter technology..

posted on Jan, 17 2018 @ 07:56 PM
XP is well known for curious USB detection issues .

Try this if and only if the device is capable of being plugged in with the system running

Unplug the device with the system powered down
Boot the system
Uninstall the driver software
Restart the system
Install the driver
After complete driver installation , plug in the device

posted on Jan, 18 2018 @ 07:42 AM
Never a problem.

Tell you what... I'll keep digging here to see what it'll take to get that thing going for you without needing to buy anything (if at all possible). Likewise, I know others here will do the same.

Let me go through the thread here and see if I can find the model of the printer you bought. I know you have an XP based system but don't know what model. I don't think the model will make a difference since the only thing we really need to get done is make it connect to your computer. The computer part of it doesn't appear to be needy as it's only pushing the plans/images to print out and that doesn't require much at all. From what I see on some of these printers is that you don't need a computer and can operate from a flash disk, if I read correctly. It said that you don't need to be connected to a computer during the printing process but all that means to me is that you need to be connected prior to for the use of the software. So let me take a deeper look here and see what I can come up with.

No giving up here... You're going to enjoy that bastard first... then you can shoot it!

posted on Jan, 18 2018 @ 08:29 AM
a reply to: Hewhowaits

Let's start with the basics and go from there.


XP doesn't allow direct control of your com ports by an application. This may not be the case because the software isn't DOS old.

Do you have anything other than the following connected to your computer?
- Keyboard
- Mouse
- Monitor
- Power cable
- Internet cable

If so... unplug everything else. Palm pilots, cell phones, printers, faxes, etc... Unplug everything except what is listed above. All of these things 'could' be using COM 1 of your com ports. (assuming COM 1 is the culprit)

BIG question... Do you have a built in or add on Modem? Something that you could plug a telephone line in to. (not an Ethernet cable - CAT5). This will most certainly be the culprit.


If at this point you are sure there are no applications using COM1, then open Device Manager, expand the Ports collection, right-click on COM1, and select scan for hardware changes from the pop-up menu. Windows may think that the device is a serial mouse (since you're using xp) and installs the mouse driver for the COM port on boot. That's not uncommon since XP likes to use COM1 for the mouse. Once you establish that nothing is connected to COM1, you're ready to plug er up and see if it connects.

If it doesn't connect at this point, I'm wondering is your mouse is using COM1. You can try this.

Open up the RUN feature and type in CMD and then hit ENTER. (Windows Key + R) It's been so long since I've used XP (was the best OS in my opinion) I forget the layout. Basically you want to run the Command Prompt (black window with big white letters)

In there, you would type:


This will disable the detection of any serial mice on COM1. Which brings me to my next question... Ball or lazer mouse? USB mouse, PS2 or Serial mouse?

Another thought would be, go into your BIOS (hit Del key on startup... might be F1 or F2 instead. It'll tell you on startup).
- Somewhere in there, you may have a list of COM ports. Might be listed as MB also. See what those settings are. You may need to turn them off (or on).

It might be under PCI devices or Integrated Peripherals. Look for:

Com1 or Serial1

You can disable it and it should allow access to your 3D printer.

I know this is a lot of information but it's everything I can think of off the top of my head. I'll look more into it and see what else I can come up with between downtimes at work.

posted on Jan, 19 2018 @ 11:47 AM
a reply to: StallionDuck

Holy cow! You really don't need to work this hard for me. It is very much appreciated though

So, basically I've tried porting and coms after everything else suggested was tried. I am able to use slicer(barely) to produce the gcode files, and then export them to a flash drive. Using the flash drive I am able to print.
Tha being said, I have no control as to how it's being printed - i.e. orientation to printbed , which is a pain in the as# because not everything like to print in a vertical orientation.
However I was able to produce a few decent prints last night. I am going to have to purchase a new computer though, as what I currently have barely can keep up with the software. It won't even open cura, and it won't even let install snapmakerjs -which is the engraving / milling program.

But, again- THANK YOU!

posted on Jan, 19 2018 @ 12:58 PM
a reply to: Hewhowaits

Never a problem, brother.

I do this sort of thing for a living. I deal with a lot of old XP and NT systems (and everything up to win7) here at work because a lot of our software and hardware still works on those systems. It's crazy how we get so much money from the use of those systems... think hundreds of dollars per day per system and we have thousands of these systems out there. So I have to stay on top of a lot of this stuff.

You probably could get a newer system for really dirt cheap. 100$ these days can get you a decent system that has windows 7-10 and even has the resources to run it properly. You can buy a brand new system for 3-400 bucks so second hand systems come out to nothing. Stay away from pawn shops though

Ebay - Tiger Direct - NewEgg - Amazon

all places you can find dirt cheep systems.

It likely wouldn't require very much in the resources department to run that bugger. Hell, you could probably just upgrade to windows 7 (if the resources are available on that system) and it'll probably work just fine.

Still, I would look at the system requirements on the software you're installing. That will tell you right away what you need minimal and you can compare those stats to what you have.

Seriously though, I don't mind helping. Hit me up anytime at all!

new topics

top topics

<< 1   >>

log in