It looks like you're using an Ad Blocker.

Please white-list or disable AboveTopSecret.com in your ad-blocking tool.

Thank you.

 

Some features of ATS will be disabled while you continue to use an ad-blocker.

 

"Posts in Thread" function broken?

page: 2
5
<< 1    3 >>

log in

join
share:

posted on Aug, 2 2015 @ 04:27 PM
link   

originally posted by: SkepticOverlord
This is the link I get when I try it on this thread: www.abovetopsecret.com/forum/thread1078338/pg1&mem=BuzzyWigs. Are you sometimes seeing something different?


The problem happens when there is more than one page of "posts in thread" for a single member.

Go to page 2, and the normal thread page comes back.

Like something is getting scrambled.




posted on Aug, 2 2015 @ 04:30 PM
link   
a reply to: xuenchen

This example shows the problem for me.

sample

the member has more than one page of posts, but "page 2" brings up the main thread.


edit on Aug-02-2015 by xuenchen because: oops



posted on Aug, 2 2015 @ 04:41 PM
link   
I tested it using the OP from this very thread. It was okay.



posted on Aug, 2 2015 @ 04:55 PM
link   

originally posted by: xuenchen
a reply to: xuenchen

This example shows the problem for me.

sample

the member has more than one page of posts, but "page 2" brings up the main thread.


This. Thanks, xuenchen.

Here's another one. www.abovetopsecret.com...
Look for my Posts in Thread. There are 2 pages worth. When you try to go to the second page, it goes to the second page of the thread.



posted on Aug, 2 2015 @ 05:03 PM
link   
a reply to: Benevolent Heretic

Yup.

Same thing.




posted on Aug, 2 2015 @ 05:04 PM
link   

originally posted by: angeldoll
I tested it using the OP from this very thread. It was okay.


This thread does not have enough data yet.

The problem shows up when a single member has more than one page of posts.




posted on Aug, 2 2015 @ 06:36 PM
link   
a reply to: xuenchen

See??? Yeah!!!!




posted on Aug, 2 2015 @ 06:38 PM
link   
a reply to: SkepticOverlord

What xuen said. Find a thread with boatloads of posts by any specific member (more than 20 posts, I guess?)

Click on that member's Posts in Thread.....
try page 2 of their posts.




edit on 8/2/2015 by BuzzyWigs because: (no reason given)



posted on Aug, 2 2015 @ 07:39 PM
link   
It's working for me. If it isn't for you, remember that ATS only sorts by your posts per page...so if you only have one post on the one page, you'll only get one post. Or if you have none, it'll return zero.

See this post also for a workaround:
www.abovetopsecret.com...



posted on Aug, 2 2015 @ 07:47 PM
link   
a reply to: Shugo

Erm, not at all sure what you mean. If someone has posted in a thread, and I click on their profile green head, it is supposed to show me their posts in thread when I click "posts in thread".

If they never posted in the thread, I wouldn't click on it to begin with.
I know how to 'go to profile' and view threads and posts and all that jazz.

????



posted on Aug, 2 2015 @ 08:00 PM
link   
a reply to: BuzzyWigs

What I am saying is that the code doesn't select every post from the thread and then condense them. It'll only show you post on this page of this thread by this member. It doesn't take every post and condense them into pagination of its own. That's why I linked you to that thread, because the user was having similar issues.

It's a php pagination issue, not a browser issue.



posted on Aug, 2 2015 @ 08:05 PM
link   
a reply to: Shugo



What I am saying is that the code doesn't select every post from the thread and then condense them.


But, it does. Check it.

ETA: Example

Page 1 is my posts only from that thread. Select another page and you will see that page of the thread rather than that page of my posts.
edit on 2-8-2015 by DenyObfuscation because: (no reason given)



posted on Aug, 2 2015 @ 08:24 PM
link   
a reply to: DenyObfuscation

Then THAT could be a browser based issue. Regardless, the original issue is a problem with pagination, and the work around is simply replacing pg1 with pg2 in the URL instead of using the backwards and forwards buttons.



posted on Aug, 2 2015 @ 08:30 PM
link   
a reply to: Shugo
But THAT IS the issue in the OP.

You're right about the workaround though. I pointed that out a couple of weeks ago in the thread that was largely ignored.

www.abovetopsecret.com...



posted on Aug, 2 2015 @ 08:33 PM
link   
Noticed it for a couple of weeks now. I use it on, for example, a space thread where JadeStar has published a large amount of data. Used to be able to read it all at once, now it just shows the first page of quotes and then kicks back to the main thread. This is one someone should fix, it's a function you can use on an 'Ask Me Anything' and read all the interviewees answers at once. Thanks for anyone who is having a go at it.



posted on Aug, 2 2015 @ 08:44 PM
link   
A bug.
But the one which is not a bug and really bugs (bothers) me is clicking the "Originally posted by" link and not being taken to the actual post (from which the link can be extracted).



posted on Aug, 2 2015 @ 09:58 PM
link   
a reply to: DenyObfuscation

Sorry I missed your thread that already brought it up.
I looked at BB&Q and didn't see anything.

Anyway - yeah.
I didn't mean to make trouble....




posted on Aug, 2 2015 @ 10:09 PM
link   
The issue with more than one page should now be fixed.



posted on Aug, 2 2015 @ 10:13 PM
link   

originally posted by: SkepticOverlord
The issue with more than one page should now be fixed.


Yup.

Works now.






posted on Aug, 2 2015 @ 10:21 PM
link   

originally posted by: BuzzyWigs
a reply to: DenyObfuscation

Sorry I missed your thread that already brought it up.
I looked at BB&Q and didn't see anything.

Anyway - yeah.
I didn't mean to make trouble....


Not my thread, I just tried to help an old friend by giving her that tip.

I never implied you were making trouble so I'm a little confused by that. Bottom line though, SO got 'er done so it's good that you brought it up.



new topics

top topics



 
5
<< 1    3 >>

log in

join