It looks like you're using an Ad Blocker.

Please white-list or disable in your ad-blocking tool.

Thank you.


Some features of ATS will be disabled while you continue to use an ad-blocker.


Help ATS via PayPal:
learn more

Need help with Huawei E3131 USB Stick - No serial mode

page: 1

log in


posted on Apr, 8 2015 @ 07:59 AM
For months now I've been using Huawei E3131 (and E3131A) on my Raspberry Pi's to auto dial and connect to my VPN. I've got over a dozen such installations in the field and they work like a charm.

But the latest batch of USB sticks I ordered came installed with the Hilink software (Firmware version 22.xx) which makes the USB sticks unusable on my Raspberry Pi's.
The Hilink software is great for the average PC user that likes plug-and-play devices. But Hilink doesn't work on the Raspberry Pi. Hilink prevents access to the serial part (i.e. direct access to the actual modem) which I need in order to connect with a Raspberry Pi.

I've read every single website, article, forum and other source on this issue, but alas nothing I tried worked.

When you Google the problem the first answer you get is to use the switchProjectMode.html page which supposedly switches the device to serial. This DOES NOT WORK. Example

Others suggest that the USB stick can be flashed and reprogrammed with 21.x version software. Only problem is to flash and reprogram the USB stick you need access to the Serial port of the device. Catch 22...

Most sources all redirect to a central point of origin of the advice: This site. I've tried everything in that thread.

I'm currently trying to install something called "Huntsman" aka ROOTer, but I don't know enough about Linux to get somewhere with it. And even though the E3131 is supported, they don't give any indication what I should install or do. The only clue I have is "Force Modem to PPP Protocol". As I understand it, the actual ROOTer software is supposedly to enable you to reprogram a Router in order for it to support 3G/4g modems. While that isn't what I want to do, the software does have the ability to disable the Hilink software on the E3131, but nowhere does anyone say how...

So in short: I have a Huawei 3131 modem with HiLink software on it. I need to disable the HiLink software and gain access to the serial port of the USB stick. Otherwise I now have about a dozen or so brand new 3G dongles that are completely useless to me.

So, if that made any sense to anyone, I would really appreciate it if there's a simple answer (or any answer will do at this stage). If not, just smile and wave.

posted on Apr, 8 2015 @ 10:25 AM
Hello gemwolf, let me first say that I have no idea about this but after a google search I found someone who seemed to have your exact same problem. I thought it might even be you but the issue was resolved for them so I will send you the link and hopefully it may help. The user with the problem appears about half way down the page.

usb modeswitch

posted on Apr, 9 2015 @ 02:36 AM
a reply to: Jonjonj

Thanks for the link.

The USB modeswitch comes into play on the Raspberry Pi side, and I have successfully switched it from storage mode to "modem mode". But even though it switches successfully I still get "cannot access /dev/ttyUSB*: No such file or directory" when I try wvdail. I've tried several dozen different Modeswitch configs already, all with the same result.

posted on Apr, 9 2015 @ 05:28 AM
I have no experience with that type of USB stick, and very little with Raspberry Pi's, but I can poke around in/modify software and firmware with the best of 'em. Is it possible to get a dump of the contents of the USB sticks? If not a full dump, are you able to extract or copy any of the pre-installed software, and upload it somewhere?

posted on Apr, 9 2015 @ 05:48 AM
a reply to: AdmireTheDistance

No, sadly not. In the "olden days" a USB dongle would appear as an extra drive when you stick it into the PC, but not with this. Nothing. If you look at the device manager, the only change I see is a "Network Adapters: Remote NDIS based Internet Sharing Device #2" that gets added. I've tried disabling/fiddling with some of the settings, but didn't have much success.

So, with normal Windows I can't get access to the software content on the USB stick. Maybe if there's some sort of software I could try? (I tried HUAWEIMODEM unlocker by asiftcn and DC Unlocker 2 Client as well, but neither of them picks up the USB stick.)

posted on Apr, 10 2015 @ 02:32 AM
a reply to: Gemwolf
Hmmm....I might know a way to dump it on Linux, but for Windows, I've got no clue. I have a job interview to go to in the morning, but after that I'll do a little research and let you know if I come up with anything.

Edit: The Hilink software....Does it prompt for any sort of installation when you put the stick Ina PC? Does it run automatically on a PC? Does it run natively on the stick?
edit on 4/10/2015 by AdmireTheDistance because: (no reason given)

posted on Apr, 10 2015 @ 05:11 AM
a reply to: AdmireTheDistance

Thanks, that would be great.

No, there are no prompts or opportunities to intervene when you plug the USB stick in. It opens your default browser with some basic settings allowing you to connect to the Internet. The stick is basically hijacked and and given complete control to the Hilink browser/software. If I could get any sort of control over the actual USB drive, then I should be able to come to a solution...

...the commercial launch of the world's first plug and link data card, the HiLink [software]. Powered by a number of patented technologies, the HiLink [software] automatically connects users to the Internet in as little as 15 seconds after the datacard is inserted into the USB port, without the need for a tedious dial-in process, driver installation or manual configuration. This is up to 75% faster than products currently on the market. The HiLink [software] is the first EDGE/GPRS/GSM-compatible product in the Huawei HiLink series that supports HSPA+network with 21 Mbps Downlink.

Which is great for the average technology challenged PC user, but not for me...

Edit: And good luck with the interview!

edit on 10/4/2015 by Gemwolf because: (no reason given)

posted on Apr, 10 2015 @ 02:41 PM
So, after doing a little bit of research, I may have found a solution...

Just to make it clear, I don't own any of the same hardware, and have not done any of this myself, so I probably won't be of much use should anything go wrong, or if anything is different than as written. Proceed with caution.

I'm putting a couple of links at the end of this, so please look through them first, and see if they look like they might be useful. As a last resort, the following steps should allow you to downgrade the firmware to a version that will allow access to the serial port(s). Please look through the other links first, though, as the information therein may work, and would probably be less of a headache.

First, you'll need to download '' from here, unless you're on Windows 8, then just Google the file name and get a newer version; any version should work.

Unzip that, install the .exe file inside of it (it appears to be clean; I checked), then go to C:program fileshuaweidriversx86 (or x64, if you're on 64 bit). Copy that entire x86/64 directory to C:tempx86 (create it if it doesn't exist).

In that directory, find 'ewser2k.inf'and open it with Notepad or Notepad++ or similar. Search for the section '[QcomSerialPort]', and below it, add the following:

%QcomDevice01% = QportInstall01, USBVID_12d1&PID_143E&MI_02
%QcomDevice01% = QportInstall01, USBVID_12d1&PID_1442&MI_00
%QcomDevice00% = QportInstall01, USBVID_12d1&PID_1442&MI_01
%QcomDevice01% = QportInstall01, USBVID_12d1&PID_1448&MI_01

Next, download the firmware file from here, and extract it with 7zip, but don't install it just yet (this .exe appears clean as well, FYI).

Now, plug in the stick, go to "" and make sure it shows some connection info, then go to "" (case-sensitive). It should go offline and windows should start looking for new drivers. When it can't find any and asks you for a location, point it to the C:tempx86 directory, and if the correct edits were made to 'ewser2k.inf', it should see the 3 drivers there. After it installs them for 'Huwaei device' or whatever it's called, it will look for drivers for something like 'a65bd63245.b65d654f'. Point it to the same x86 folder, and let it install the same drivers again. Now, back on (I think), you ought to see some COM ports. Don't remove the stick at this point, or you'll have to start over.

For the next part, you have 2 options:

1) Download '3G Modem Mode Switcher' from here, extract and isntall, then click the "1st button on the left" a few times. I haven't installed it, but I believe it is in Cyrillic, and that is the only explanation given lol.

2) Download Tera Term (ttermpro.exe) from here and install it (again, looks clean). Open it up, and point it to the device manager COM port with the description "user gui". Send the following AT command:


...And it should give you an 'OK' reply, confirming that you're connected correctly. That AT command will switch it to the default modem mode instead of the hilink mode, but should you need to switch it back, you would use the following AT command:


Next, remove the stick from your PC/laptop, and re-insert it. If it shows COM ports and you're able to re-connect through Tera Term, everything's good. If so, install the firmware that you downloaded earlier (there should be a .exe in the zip file you downloaded). During the installation, if it looks for drivers, point it again to your C:tempx86 directory. Once it completes, it should be back on a previous firmware, and you should have access to the serial port(s)...

OTHER LINKS (read these first): post10250878
Good luck!

Edit: Some of the above links may show different model names (I can't remember for sure; looked at a lot of things lol). If so, don't dismiss the information just because of that. Even if those sites reference a different model, the discussions that led me to them were about the model you have, and claimed the information is also valid for your model.
edit on 4/10/2015 by AdmireTheDistance because: (no reason given)

posted on Apr, 10 2015 @ 03:32 PM
Thank you so much for the effort. I honestly appreciate it!

originally posted by: AdmireTheDistance
Now, plug in the stick, go to "" and make sure it shows some connection info, then go to "" (case-sensitive). ...

That's the biggest problem. All methods described on all sites rely on the fact that the switchProjectMode works. It would appear that the latest version of the firmware doesn't have that page anymore, as I explained in the OP... If it did, then I would've had easy access to the serial modem to do my thing.

I did however have a slight breakthrough late this afternoon...

I happened upon these instructions:

In my experience Haewei tech support don't know how to do this, and nor does anyone else on the planet... It is crazy! I got part first hurlde and seemed to be very close. I did the following:

1. Get API token by going to

Use token in step 2 instead of 1099746139


echo "1" | curl -X POST -H "__RequestVerificationToken:1099746139" -H "Content-type: text/xml" -d @-

Download curl ... =2000%2FXP
in cmd window
echo "" | curl -X POST -H "__RequestVerificationToken:1099746139" -H "Content-type: text/xml" -d "1"

This seemed to do what the missing switchProjectMode url should do.

But they are incomplete. After following the Windows instructions, something did seem to happen. 4 Huawei Modem devices was added and visible in the device manager. However, they didn't work as Windows couldn't find any drivers for them. Which lead me on a wild goose chase to find drivers for the specific device... After some time and no results I called it a day.

I need a break from the cursed, stupid modems, so I'll start fresh on Monday and try the same thing on a Linux setup. It's a fresh lead, so at least I seemed to have moved one step forward; and after a week's frustration, it's something.

Thank you once again for the effort. If you discover something worthwhile in the mean time, it would still be appreciated!

posted on Apr, 10 2015 @ 04:10 PM
Ah, I must have misread or misunderstood. I didn't realize that you couldn't access switchProjectMode at all....Take your break! I know all too well the headaches things like this can cause lol.

When you do come back to it, though, I'd recommend getting back to the point where it saw the devices, but couldn't find drivers, and then try editing the ewser2k.inf file as outlined in part of the instructions I posted, as it apparently allows 3 more drivers to be detected. It's worth a shot, at least, and it's just 3 lines in a text file, so it's easily reversible if it doesn't help.

Edit: Just out of curiosity, what sort of stuff are you using the Raspberry Pis "in the field" for? If you can't/prefer not to answer, it's cool. Just curious.

edit on 4/10/2015 by AdmireTheDistance because: (no reason given)

posted on Apr, 10 2015 @ 04:48 PM
a reply to: AdmireTheDistance

Earlier this week I explored the Mobile Partner software (ewser2k.inf) route, but that was a dead end as well. Long story - let's just say, it obviously doesn't work.

I use it as part of a Smart Metering solution. One of the companies (don't ask) I work for is an electricity reseller, and when Smart Meters came into play we tried several different solutions, and in the end the best (fastest, most reliable) solution was a combination of built-in Smart Meter technology, wireless mesh networks and Raspberry Pis. The Pis act as portal between our server and the metering sites. It all works perfectly well - until they change the Firmware of the hardware you've been using...

In-between all the other problems and projects and busy doing R&D to get rid of the wireless mesh and let the Pi be a data concentrator and communication portal. We're already in the first testing phase, but that's not really a priority right now.

I know it all sounds extremely dull and boring, but I love R&D - developing something new is very fulfilling. Just frustrating to be held up by something as stupid as modem firmware that worked perfectly fine as it was. It will however be really satisfying to cross this bridge. Eventually.

On a side note - how did the interview go?

posted on Apr, 10 2015 @ 10:54 PM
a reply to: Gemwolf

Doesn't sound dull at all. I spend a lot of my free time programming and writing apps, so I can sympathize with that sort of frustration. Heck, I've spent the past 4 days trying to figure out how to register a specific button click on a specific device, because the available SDK is next to worthless. But when things finally work how they're supposed to , it's a great sense of accomplishment.

That's a pretty novel use of the Raspberry Pis. Not something that I would have thought of, but quite the elegant solution!

Back to your problem....I've done a bit more digging, and I haven't been able to cone up with anything else. I know someone who's about as much of an expert as one can be when it comes to dissecting/modifying/replacing modem firmware. I've sent him an email asking if he has any ideas or suggestions, and with a link back to this thread. If he's not familiar with the particular model (or one similar) he likely won't be able to provide any further insight, but if it is one he's familiar with, I can just about guarantee he'll have an answer. I'll let you know what he has to say.

The only other avenue I can really think of, is to maybe contact Huawei (if you haven't already) and see if they might be able to provide you with x number of units with the previous firmware. Being that it's for a company and not an individual, you might get lucky.

And the interview went well, thank you for asking! I should start work next week. Nothing special, just a retail management position, but I'm planning on going back to school in May, and it'll pay the bills while I finish my degree.
edit on 4/10/2015 by AdmireTheDistance because: (no reason given)

posted on May, 25 2015 @ 05:35 AM
I received some queries about this problem, and whether I managed to fixed it.

I did, as a matter of fact, find a way to get the E3131 modem working on the Raspberry Pi. I found a dirty way to "fix it". It may not work for everyone but it works for me, and that's pretty much all that matters to me...

So, to get a Huawei E3131 to work on a Raspberry Pi in modem mode with HiLink disabled, these are the steps I followed:

***Warning! These steps may cause your Huawei Modem to be "bricked" - so use at your own discretion... Carefully read the notes BEFORE you continue***

- I did this on a Windows XP machine, as my Laptop with Windows 7 didn't exactly co-operate. Maybe others have better luck with Windows 7.
- You will need the "Huawei Hilink E3276" firmware updater. It can be downloaded from several pages such as the webpage. The exe file name is "UTPS23.". You will also need the "E3531s-6_E3533Update_21.318.05.00.exe" Firmware wizard. (See here)
- Important: You may be asked for an Unlock code. There are several software packages and sites you can get an unlock code. Don't pay for it, there are free versions. I can't link to these as they are considered hacking tools, which is forbidden by the T&Cs.

1. Plug in the E3131. The Internet Browser will open up with the HiLink page.

2. Run the UTPS23...exe update wizard (see notes for more info).

3. The Firmware Update wizard will begin by searching for devices, and you may notice the Windows "Adding new Hardware" pop-ups in the right-hand corner. If it found the device it will begin "Downloading Programs..." This takes several minutes. Do not unplug the modem before it is done!!!

4. When it's done, a message will appear that says "Error: Software download failed." Even though it failed, it did the important part, i.e. it flashed the firmware. Now run the "E3531s-6_E3533Update_21.318.05.00.exe" Firmware update. It should successfully update the modem.

5. The USB modem is now basically "bricked" and unusable on Microsoft Windows, unless you can get the E3131 drivers from somewhere. Good luck with that...

6. You are now extremely worried and disappointed because your Modem is now useless. But don't worry, Raspberry Pi to the rescue. You are now done with the PC, so you can unplug the Modem.

7. Turn on your Raspberry Pi. Don't plug in the modem yet. On the Raspberry Pi you'll need to install the latest version of USB Modeswitch. Once you're happy it's installed and up to date, you can plug in the E3131 USB modem.

8. Edit your USB_Modeswitch.conf file located in /etc/usb_modeswitch.conf as root. (i.e. "sudo leafpad /etc/usb_modeswitch.conf"). Change it to look something like this:

# Huawei E3131
DefaultVendor= 0x12d1
DefaultPoduct= 0x15ca
TargetVendor= 0x12d1
TargetProduct= 0x1506

^ This is just the important parts of the changes and not the entire contents of the file. Leave the rest of the file as it is.

9. Open a terminal and run the "lsusb" command. You should see Huawei Modem listed. Mine is listed as "12d1:15ca Huawei Technologies Co., Ltd.".

10. Run the command
sudo usb_modeswitch -v 0x12d1 -p 0x15ca -c /etc/usb_modeswitch.conf -I

It won't switch without the "-I" (capital i) switch.

11. Run "lsusb" once again, and you should see the Huawei modem now listed as
"12d1:1506 Huawei Technologies Co., Ltd. E398 LTE/UMTS/GSM Modem/Networkcard".

It is now usable with wvdial etc. as a regular modem

If you don't see it, I suggest a hard reboot. And then try switching it again. It doesn't switch automatically when you plug it in, so I've included the sudo usb_modeswitch command in my /etc/rc.local file with a sleep delay to make sure the Raspberry Pi is properly booted before switching the modem. My setup also calls wvdial from rc.local, so every time the Raspberry Pi powers up, it connects automatically to my APN. It also has a watchdog, so if it looses the connection it automatically soft reboots itself.

I know it's a very dirty way of getting there, and probably has one or two unnecessary steps. But it works for me. Hope it helps someone else.
edit on 25/5/2015 by Gemwolf because: (no reason given)

new topics

top topics


log in