It looks like you're using an Ad Blocker.

Please white-list or disable AboveTopSecret.com in your ad-blocking tool.

Thank you.

 

Some features of ATS will be disabled while you continue to use an ad-blocker.

 

Apache2 Configuration Issues

page: 1
1

log in

join
share:

posted on Jan, 30 2015 @ 12:20 PM
link   
Hello.

I recently have been setting up a server to host some content that would eat up my bandwidth on my paid hosting provider.

I have run into some issues with the configuration. It is an Ubuntu server environment called Zentyal.

Now i have already apt-get install apache2. I tried to follow the virtual host configuration in the original documentation for the server OS.

As per TOS i have redacted the url's xxx.xx

interceptor@zen:/etc/apache2$ sudo service apache2 restart
* Restarting web server apache2 [fail]
* The apache2 configtest failed.
Output of config test was:
apache2: Syntax error on line 219 of /etc/apache2/apache2.conf: Syntax error on line 16 of /etc/apache2/sites-enabled/xxx.xx.conf: /etc/apache2/sites-enabled/xxx.xx.conf:16: < Directory > was not closed.
Action 'configtest' failed.
The Apache error log may have more information.


What does the directory was not closed mean?

I can ping my ip and i get a response. In the browser i get page timeout. I have already made sure the proper ports are open and my domain resolves the the proper ip. I have also made firewall entries to allow traffic on those ports.

I believe that i messed up something when configuring my vhosts.

Anyone of you Linux gurus have an idea? I can provide redacted versions of the xxx.xx.conf if needed.
edit on 1/30/2015 by shaneslaughta because: (no reason given)




posted on Jan, 30 2015 @ 12:37 PM
link   
a reply to: shaneslaughta

My guess would be that you missed the ending '</Directory>'* tag?

It's a syntax error in the config file - not a startup or runtime error...

Worst case; Zip the config and upload it somewhere and I'll take a look...


edit on 30-1-2015 by DigitalJedi805 because: (no reason given)

edit on 30-1-2015 by DigitalJedi805 because: (no reason given)



posted on Jan, 30 2015 @ 12:40 PM
link   
Hmpf..............At first I thought there were problems with a new attack chopper......silly me...........



posted on Jan, 30 2015 @ 12:42 PM
link   
a reply to: shaneslaughta

From your log error it seems there is either a typo somewhere or you need to close the directory definition.

This is a windows example but it's quite similar:

Make sure that you have a closing directory setting.

whatever configurations


Hope it helps!



posted on Jan, 30 2015 @ 12:45 PM
link   
Hmmm.

So

< Directory /srv/www/xxx.xx >

Should be

< Directory /srv/www/xxx.xx /Directory >

?
edit on 1/30/2015 by shaneslaughta because: Haha got nailed with the tags



posted on Jan, 30 2015 @ 12:52 PM
link   

originally posted by: shaneslaughta
Hmmm.

So

< Directory /srv/www/xxx.xx >

Should be

< Directory /srv/www/xxx.xx /Directory >

?


More like so:

 


<directory /srv/www/xxx.xx>
// Virtual Directory Directives
...
</directory>

 

edit on 30-1-2015 by DigitalJedi805 because: (no reason given)



posted on Jan, 30 2015 @ 12:59 PM
link   
a reply to: DigitalJedi805

Beautiful thanks.
Now another error.

Output of config test was:
AH00526: Syntax error on line 19 of /etc/apache2/sites-enabled/xxx.xx.conf:
AllowOverride not allowed here
Action 'configtest' failed.

In .conf AllowOverride is set to None. Should that be False not None?


Edit: Scratch that. In my haste to get this working i ended the directory before the arguments.





edit on 1/30/2015 by shaneslaughta because: (no reason given)



posted on Jan, 30 2015 @ 01:03 PM
link   

originally posted by: shaneslaughta
a reply to: DigitalJedi805

Beautiful thanks.
Now another error.

Output of config test was:
AH00526: Syntax error on line 19 of /etc/apache2/sites-enabled/xxx.xx.conf:
AllowOverride not allowed here
Action 'configtest' failed.

In .conf AllowOverride is set to None. Should that be False not None?




No - 'None' is the proper argument; but you may not be able to use it, depending on the rest of your config...

Per the Apache manual:

AllowOverride is valid only in <Directory> sections specified without regular expressions, not in <Location>, <DirectoryMatch> or <Files> sections.

I also note that it seems more appropriate to use 'AllowOverride' in .htaccess files - or at least more common...

Can you post your whole <Directory> config?



posted on Jan, 30 2015 @ 01:04 PM
link   
a reply to: shaneslaughta

Lol - edit noted.

Cheers brother. Best of luck.

I'll keep an eye on this post for a little while longer - let me know if anything else turns up.

 


If you post something and I don't get back - PM me and hopefully I'll see it sooner than later...
edit on 30-1-2015 by DigitalJedi805 because: (no reason given)



posted on Jan, 30 2015 @ 02:02 PM
link   
Awesome, Im getting http response header.

A million thanks just wont do.



posted on Jan, 31 2015 @ 03:33 PM
link   
a reply to: shaneslaughta

No problem doggy - glad to be a help.




new topics

top topics



 
1

log in

join