It looks like you're using an Ad Blocker.

Please white-list or disable AboveTopSecret.com in your ad-blocking tool.

Thank you.

 

Some features of ATS will be disabled while you continue to use an ad-blocker.

 

Need help with Cairo Dock/Lubuntu

page: 1
2
<<   2 >>

log in

join
share:

posted on Jan, 13 2015 @ 07:02 AM
link   
Hello, I just installed the Cairo dock and I have to say I really like it! The only issue I'm having is that it won't autostart on startup. Since I'm running lubuntu there aren't many programs that I can use to correct my problem...to correct this I'm pretty sure I have to go through the terminal.

I've found a half assed explanation on some forums, but since I'm creating/moving folders I want to make sure that I have the right commands the first time.

From what I've been reading I have to creat a file in ~/.config/autostart So am I supposed to type cd ~/.config/autostart ? Once I'm there what do I do?

I'm still climbing the noob ladder when it comes to Linux so if you could be specific in your answer I would greatly appreciate it.

I do have a few more questions regarding this application, but I just want to tackle one problem at a time.

Thanks in advance!




posted on Jan, 13 2015 @ 07:39 AM
link   
First you will have to be root to be able to create that file. That should be sudo -s, but your user account must be part of the administrator/admin group for it to work.

I just checked and in Linux mint based off Debian like Ubuntu, it has a start up applications section in preferences. You can add it easily there, if you have that option?

The way to do this properly depends on the OS version and window manager. What versions of Ubuntu are you running and what window manager please.



posted on Jan, 13 2015 @ 07:46 AM
link   
Im running Lubuntu 14.10 ....I'm not sure what you mean by window manager? Also I'm pretty sure I don't have a startup application menu, I've looked..Maybe I just missed it. Since Lubuntu is a lightweight version of Ubuntu there a lot programs missing.
edit on 13-1-2015 by cavedweller88 because: (no reason given)



posted on Jan, 13 2015 @ 07:49 AM
link   
I found something called "LXSession Configuration" which has a startup options menu, Zeitgeist Datahub is listed and checked which I'm pretty sure is the Cairo Dock...Not sure why it isn't starting up?



posted on Jan, 13 2015 @ 08:16 AM
link   
Lubuntu is an Ubuntu flavor. You need to add it to the programs that autostart - if memory serves there should be an option to do so if you right click on Cairo dock itself - just not on any of the icons... on a section of the border and catching that can be tricky.

Once you get that menu open there should be a "launch dock at startup" selection.



posted on Jan, 13 2015 @ 08:18 AM
link   
a reply to: Hefficide

I've done this, I believe that is the reason it is listed in the startup programs...but, for some reason it still doesn't start.



posted on Jan, 13 2015 @ 08:21 AM
link   
a reply to: cavedweller88

This might help

Adding it to start should be easy. Just search for startup and you'll find the list of applications that start upon boot. There will be an "add" button. Just click that and add Cairo Dock to it through that menu. The only thing you'll have to do beforehand is know where in your directory tree Cairo dock installed. If a desktop shortcut was created you can get the path to the executable from it.



posted on Jan, 13 2015 @ 08:23 AM
link   
Ahhh. I missed the L, i need to slow down my reading a bit. I didn't mean the window manager per say but the actual desktop environment (LXDE). This is the part of the operating system that makes it lightweight and responsive. I had a bunch of issues with Ubuntu and Unity being a resource hog and causes an otherwise normally functioning machine to hang a bit.

Personally i have steered away from Ubuntu in recent years because of unity.

This link has a bunch of great info on how do do just what your looking to do.
glx-dock.org...

If a solution cant be found through the first link your going to have to get your fingers dirty

Continue Below


Open the file manager (by default PCManFM), go to /usr/share/applications. Right-click on the program you want to be added to your autostart programs, and click Copy. Now, go to ~/.config/autostart in PCManFM, right-click and click Paste. The program should be added to your autostart programs now, but double-check by clicking the LXMenu down left, click Settings, and then Desktop Session Settings.

askubuntu.com...

(WARNING) You can break your system if you change move or delete any files inside these folders.However i don't believe you can access those directories directly in the file manager without running as root. This protects the system from accidents

You must sudo PCManFM to open the file manager with root access to make any changes to the file system.

If this didn't help you you get confused or hit a dead end just come on back and ill do my damnedest to get you sorted.



posted on Jan, 13 2015 @ 08:26 AM
link   
Scratch that.
edit on 1/13/2015 by shaneslaughta because: (no reason given)



posted on Jan, 13 2015 @ 08:30 AM
link   
a reply to: shaneslaughta

Ubuntu Gnome is my preference. I hate Unity. I know a lot of people hate Gnome 3, but I love it. Plus I have Cinnamon in case I ever get a longing for a permanent bottom task bar... I have yet to have that longing.

Cairo Dock has a 2D and 3D version I believe and will adapt depending upon what version of Direct X is installed. I have a laptop that runs it smoothly in 2D with a generic onboard Intel graphics chip.



posted on Jan, 13 2015 @ 08:34 AM
link   
a reply to: shaneslaughta

What does it mean to run with/without backend?


BTW thanks for all the help everyone...I have to go to work soon, but I'll be sure to try this when I get back and let you know if it solved my problem.



posted on Jan, 13 2015 @ 08:43 AM
link   
a reply to: cavedweller88

The easiest way i can explain this to you.

The backend is a software packages that are and i use the term loosely, "hardware specific".
What package you need depends on the video card your using.

But seeings how you already said in your OP that you like the dock, i am assuming you have it working so that is a non issue other than to boot problem.



posted on Jan, 13 2015 @ 08:45 AM
link   
a reply to: Hefficide

Yea, I don't like Unity either...Gnome for the win.

I have a generic graphics chip as well and a rather old computer (Dell D620), but everything seems to be displaying in 3d.



posted on Jan, 13 2015 @ 08:52 AM
link   
a reply to: Hefficide

I see. No issues with gnome here, one of my favorites actually. Though i do like a lightweight simple interface, my nix boxes run headless and i access them remotely. So i tend to stick to the lightest gui i can find. I dont access them much they just tend to sit around idle most of the time.

Actually i use linux to power my network switch. AKA a single core Athlon 64bit with a gig of ram and 6 nics
It also provided me with stability and throughput much greater than cable modem/router or dsl counterparts. And from a security aspect, much better off than crap you buy at walmart. I love a machine that can sit on for months without skipping a beat.


Linux stability: if you don't have it your doing it wrong.
edit on 1/13/2015 by shaneslaughta because: (no reason given)



posted on Jan, 13 2015 @ 10:14 AM
link   
You could always do a search on Ubuntu forums.
As I'm the only user on my machines I tend to add autostart apps in /etc/xdg rather .config in my home folder.
There a re a couple of options within that folder in Lubuntu that I can't recall offhand - Lubuntu & lxsession I think. I also can't remember the exact syntax for Lubuntu.

Sorry, the file to edit is /etc/xdg/lxsession/Lubuntu/autostart, if you're going to go down this route

I'm currently on a Xubuntu box & just edit the autostart file in /etc/xdg.

Why have I bothered? This is really no help at all...

It's a bit old, but may be of some help:
ubuntuforums.org...

edit on 13-1-2015 by EnochRoot because: (no reason given)

edit on 13-1-2015 by EnochRoot because: (no reason given)



posted on Jan, 13 2015 @ 10:24 AM
link   
Oh yeah, if you're going to edit the file with a graphical application like Leafpad use gksudo to launch it as root, not just sudo.

Simply sudo will work for a cli editor such as nano.



posted on Jan, 13 2015 @ 10:37 AM
link   
a reply to: EnochRoot

I may be mistaken, but if you use sudo your file manager it will give you root in the file manager and it allows you to edit any text file in a graphical editor.

Myself i prefer vi



posted on Jan, 13 2015 @ 11:07 AM
link   
a reply to: shaneslaughta
It'll probably be okay to be honest.
However, I've picked up from somewhere that when launching graphical applications as root gksudo is preferable as there is the possibility of a permissions screw up.
I'm not sure how likely that is, or even why it would happen, but I'm a belt & braces kinda guy with these things...& for the sake of 2 extra characters...



posted on Jan, 14 2015 @ 09:31 AM
link   
PROBLEM SOLVED! I think I was just overthinking my problem, what I did seems a rather simple solution. All I did was go into my listed programs /usr/applications I found Cairo and copied it. Then I went to /home/username pressed CTRL+H found the .config file and just pasted Cairo in there. Restarted and it seems to work fine.


My next problem/question may not be able to be fixed since I'm using an older computer.....Since it's rather hard to explain I took a screen grab of my desktop.



As you can see whenever I try to hover the dock it exposed quite a bit of my desktop, I'm not sure if this is supposed to happen or what? Another issue that happens about 10% of the time is that if I were to hover the dock it locks the desktop exposure in place(if that makes sense)...So what you see of the desktop exposed in the above picture will stay exposed even if the dock has gone back to its hidden position.

Not a big deal if this problem can't be solved though, just curious if this is common or even supposed to happen.



posted on Jan, 14 2015 @ 12:10 PM
link   
a reply to: cavedweller88

Does your system support GTK3? If not you might have to download an older version of the dock.

Also you can make sure that it's not running on Compiz and is using GLX to create the graphics.



new topics

top topics



 
2
<<   2 >>

log in

join