It looks like you're using an Ad Blocker.

Please white-list or disable AboveTopSecret.com in your ad-blocking tool.

Thank you.

 

Some features of ATS will be disabled while you continue to use an ad-blocker.

 

Ubuntu 14.04LTS Drivers Help

page: 1
0
<<   2 >>

log in

join
share:

posted on Dec, 9 2014 @ 02:32 PM
link   
Hello,

I decided to switch back to Ubuntu after my XP started to really slow down on me.

Anyways I forgot how much work Linux distros can be if you don't understand how to tune it up and I'm having some freezing issues which never really happened to me before.

I'm running Ubuntu 14.04LTS on a Dell Latitude D620 laptop. I've done the basic sudo apt-get update && sudo apt-get upgrade, then I ran the update again to make sure that everything was up to date.

I think the problem may be with the drivers which is where I get lost. I have no idea how to search for what drivers I have, let alone what drivers I need. There seems to be a lot of conflicting information when I search on google and other sites. The last thing I want to do is make matters worse for myself which is why I am coming to ATS for help.

I should be online all day to provide any additional information that is needed to help my situation.


Thank you in advance!




posted on Dec, 9 2014 @ 03:11 PM
link   
a reply to: cavedweller88

modprobe -l

Will tell you what drivers are currently loaded. man modprobe for more info on the usage.

Why do you think it's a driver issue? What are the symptoms?



posted on Dec, 9 2014 @ 03:36 PM
link   
I tried running the modprobe...didn't work. is it Sudo modprobe -I ? That did'nt work either.

The reason I think it's a driver issue is that seems to be a common issue with the freezing problems discribed in the message boards.

running 2 tabs in a browser is nearly impossible, opening up the software center takes a few minutes and freezes in the process and there is a slight lag in streaming video. Audio seems to be fine across the board though, last time I used Ubuntu I had issues with the audio.



posted on Dec, 9 2014 @ 03:38 PM
link   
a reply to: cavedweller88

What are the computer specs?



posted on Dec, 9 2014 @ 03:52 PM
link   
Memory--- 992.5 MiB

Processor--- Intel Cor 2 CPU T 550 2 1.66GHz x 2

Graphics--- Intel 945GM x86/MMX/SSE2

OS type--- 32-bit

Disk Space---38.1GB



posted on Dec, 9 2014 @ 04:09 PM
link   
Have you tried "dmesg"? That lets you read all the grumbles and general chatter from the device drivers.



posted on Dec, 9 2014 @ 04:21 PM
link   
a reply to: cavedweller88

From the Ubuntu system requirement page:


Ubuntu Desktop 11.04 and up uses Unity as the default GUI while the previous releases used GNOME Panel by default. In order to run Unity the system needs a more capable graphics adapter – see more here or below:

* 1000 ΜHz processor (about Intel Celeron or better)

* 1024 MiB RAM (system memory)

* 3D Acceleration Capable Videocard with at least 256 MB



You are running the bare minimum RAM and your graphics card is also at the minimum requirement for Unity.


Have you tried running gnome classic? How does that run?

Source: help.ubuntu.com...



edit on 9-12-2014 by sixswornsermon because: edit to add source



posted on Dec, 9 2014 @ 04:45 PM
link   
I have the same laptop running 12.04, and I myself don't like unity.

I wonder if your problem is overheating, sounds like problem I was having.

Type: sensors (In terminal)
This should tell you what temp you CPU and gpu are running.

I'm betting you don't have the i8kmon driver or i8k-utils installed. I had to search around and it has something to do with the way dell has their BIOS and monitoring the CPU and fan speeds. The i8k-utils is needed to monitor and control fan speeds in dell laptops.

Search around for dell laptop fan speed or overheating. When I get on my laptop later i'll link the search pages I used to fix the problem.



posted on Dec, 9 2014 @ 04:45 PM
link   
No I haven't tried this, Do I need make a whole new boot disc? Or can I do this through the terminal?



posted on Dec, 9 2014 @ 04:46 PM
link   
Slap a couple of GB more memory in would be my advice, probably its dirt cheap and if you want to keep to the 32 bit version then 3gb is fine, when memory is tight most os's roll in and out pages of memory to disk which is a hell of a lot slower causing those pauses, and after spending a day on a early 1980's mainframe calculating the diskspace required per process that ran on it should it need to be paged out i still have nightmares 15 years later



posted on Dec, 9 2014 @ 04:46 PM
link   
a reply to: IncognitoGhostman

No, I don't think its an over heating issue.



posted on Dec, 9 2014 @ 04:47 PM
link   
a reply to: cavedweller88

This should get you there if you want to try gnome classic:

www.howtogeek.com...

Also, checking to see about heat issues as ghostman suggested is a great idea.



posted on Dec, 9 2014 @ 04:51 PM
link   
a reply to: sixswornsermon

The fan seems to be spitting out relativly cool air at least cooler than it was when i was running XP



posted on Dec, 9 2014 @ 04:51 PM
link   

originally posted by: cavedweller88
a reply to: IncognitoGhostman

No, I don't think its an over heating issue.


When mine gets up above 55c it freezes up and takes forever to do anything on it. After I went through the steps to install the monitor and lower the fan speed settings my freezing issues went away



posted on Dec, 9 2014 @ 04:54 PM
link   
a reply to: cavedweller88

Well that's good. Go ahead and run gnome classic and then have as many sensors as you can find start with the session for some rice.



posted on Dec, 9 2014 @ 05:25 PM
link   
a reply to: sixswornsermon
Gnome seems to be FAR more responsive! Thank you very much for helping me with this! I appreciate your help very much.



posted on Dec, 9 2014 @ 05:26 PM
link   
a reply to: IncognitoGhostman

For future reference what monitor/program did you use to adjust the fan speed?



posted on Dec, 9 2014 @ 05:34 PM
link   
a reply to: cavedweller88

No problem bud. Glad it's working out better.



posted on Dec, 9 2014 @ 06:06 PM
link   



posted on Dec, 11 2014 @ 09:46 AM
link   
Sorry it took a bit to get back to you.

Lm-sensors won't work to control fan speeds with dell and neither will adding acpi to grub since the BIOS doesn't have that functionality in Dell.

What i got to work was off these
fan control on this page they have some commands with emacs in it, I'm gonna guess it's not installed so either replace it with "vi" or better yet "gedit" to edit or create the files.
LM Sensors will allow you to monitor the temps and speeds, just not control them.
At the bottom of Disable BIOS fan control there are steps to disable the BIOS from controlling the fan. I did this because I noticed my fan would come on for 10-15 secs and then shut-off. It would just keep doing this and wouldn't lower the temp. This was also when I noticed after a minute or so my laptop would start freezing.

As these pages explain fan control for Dell laptops isn't enabled by default, so you have to go through some step. The page that Sixswornsermon has some of the same info on the ones I linked they just go into more detail.

Just wanted to add that I didn't like unity myself and totally removed it and reverted back to gnome. I have since gone with ArchLinux and ICEwm and have no plans of returning to Ubuntu after 15 years of using linux. Arch is a bit harder to install, specially a GUI for it. The best part is it's built how you want and now in my opinion the BEST.

edit on 11-12-2014 by IncognitoGhostman because: added and spelling corrections



new topics

top topics



 
0
<<   2 >>

log in

join