It looks like you're using an Ad Blocker.

Please white-list or disable in your ad-blocking tool.

Thank you.


Some features of ATS will be disabled while you continue to use an ad-blocker.


Help ATS via PayPal:
learn more

usb ports all keep turning on and off constantly

page: 1

log in


posted on Oct, 22 2014 @ 08:50 PM
can't use my usb mouse, headset, nothing. The laptop is a late 09 model, asus G60v

I think i just need to buy a new laptop or something. my touchpad wont scroll any more so i have to use my down arrow key and yup all drivers are up to date on that so i dont know what the issue is.

Any ideas to one or both? should i try reformatting?

posted on Oct, 22 2014 @ 08:53 PM
Not sure about the usb ports. Try to uninstall them, and then reinstall in the device manager. For the touchpad, go to your control panel, and under mouse or pointing devices, go to like the last tab and click on reset all devices. I have to do this every time my laptop restarts. Hope this helps!

posted on Oct, 22 2014 @ 09:04 PM
Have you already tried turning off power management for all of the USB root hubs?

Look in the Device Manager: USB root hub properties > Power management >

Uncheck the box that "allows the computer to turn off this device to save power"...

Windows sometimes has a habit of switching off USB ports to save power.

edit on 22-10-2014 by Murgatroid because: I felt like it..

posted on Oct, 22 2014 @ 09:04 PM
a reply to: sarra1833

Have you tried a different USB device? In all the ports?

Some ports may be damaged, if not then the software is. Have you ever reinstalled your laptop since you got it? Which OS?

posted on Oct, 22 2014 @ 09:05 PM
Try darkwingduck's suggestion first.

If that does not work then the problem is likely wear and tear.

It can be fixed, or at least I have fixed a number of USB ports and it is simple IF you know how to disassemble your laptop to the stage of getting to the USB ports.

There is a little tang in the female port that needs to be pushed down a small amount to make the contacts connect again.

Easy job but time consuming.

On the other hand, what have you got to loose.

Utube is a great place to get instructions for the disassembly instructions.


posted on Oct, 22 2014 @ 09:06 PM
reset your power options in control panel ..also go into advanced and check USB sleep is off.

Boot into bios and reset config data for the bios escd. if available.

If all fails download Driver Booster 2 Free

Works very well
good luck

posted on Oct, 22 2014 @ 09:30 PM
just read this also could be a trojan try scaning system with super anti spyware

posted on Oct, 22 2014 @ 09:33 PM
a reply to: darkwingduck

I couldn't find that place. I looked.

posted on Oct, 22 2014 @ 09:35 PM
I Have to get to work soon here but i'll be running through all these hopeful fixes when i get home. thanks everyone!

posted on Oct, 22 2014 @ 09:39 PM
Another possibility is the power settings...

For your selected power plan, under advanced settings/USB settings/USB Selective suspend setting - try setting it to disabled.

More here:

Next we need to adjust the Power Plan Settings from the Power Options in Control Panel.

1. Click the Start button and type: edit power plan. Or go to Control Panel, and Select Power Options.

2. Click Change advanced power settings.

3. Then scroll down to USB settings and click the little plus next to USB selective suspend setting. Set both the On battery and Plugged in settings to Disabled then click OK to apply changes.

posted on Oct, 22 2014 @ 09:46 PM
a reply to: sarra1833

Lg virus worldwide hitting usbs flashes up on it

posted on Oct, 22 2014 @ 10:10 PM
a reply to: sarra1833

Right click on the computer icon on your desk top. Then click on properties, and it will be there.

posted on Oct, 22 2014 @ 10:22 PM
You might try downloading and burn copy of linux Ubuntu to a CD on another machine. Then use the CD to boot your laptop in Ubuntu. If you still have the problem; than the situation is not related to windows and is related to your hardware.

Good Luck

posted on Oct, 23 2014 @ 05:01 AM
a reply to: rimkunw

always a good idea as it quickly allows you to say hardware or software normally so you don't have to spend hours faffing around

but anyway make sure anything of importance is backed up (preferably a couple of times to different locations) as its getting a bit old and most drives are rated to last 3-5 years under usual usage so its reaching the point where its becoming possible and its a hell of a lot cheaper for a new drive than paying for someone to sort out your problems in a clean air lab

posted on Oct, 23 2014 @ 05:56 AM
a reply to: Murgatroid
dont want to speak too soon but I think that fix worked. Thanks in advance if it did! If it still goof ups, I'll be trying more options here.

posted on Oct, 23 2014 @ 05:59 AM
a reply to: darkwingduck

I found the device mgr, have used it in the past, but my mouse option doesn't have what you're talking about. I was getting ready for work at the time and my reply showed my rushing by not being more specific. Sorry about that.

I don't have any means of 'resetting all devices'. I have windows 7 if that helps. 64 bit

posted on Oct, 23 2014 @ 08:16 AM
a reply to: sarra1833

Glad to hear it...

For desktops, the USB root hub fix will usually handle the majority of USB issues.

Because my experience with lappys is limited, I wasn't sure about the power option fix.

Anyone else see in the news earlier in the year about how Bill Gates couldn't even figure out how to install his own operating system?

I suspect that Mr. Gates is more interested in Agenda 21 than quality products and satisfied customers.

edit on 23-10-2014 by Murgatroid because: I felt like it..

posted on Oct, 23 2014 @ 11:54 AM
a reply to: sarra1833

I have windows 7 also. Check control pane/mouse/device settings. There is a button on the bottom that says reset devices.

new topics

top topics


log in