It looks like you're using an Ad Blocker.

Please white-list or disable in your ad-blocking tool.

Thank you.


Some features of ATS will be disabled while you continue to use an ad-blocker.


Help ATS via PayPal:
learn more

please help me with netflix on my linux box

page: 1

log in


posted on Sep, 17 2014 @ 08:45 AM
i have ubuntu and i use chrome. i went to the app store through chrome and tried to install netflix several times an i keep getting an error. here is the message.
Could not install package because a utility process crashed. Try restarting chrome and trying again.


i really dont know anything about dealing with linux. ive been using ubuntu for about 6 months and never really tried to install anything except this.

please help me figure this out.


posted on Sep, 17 2014 @ 08:50 AM
i pulled up a how to link...

it said open terminal and run this.... so i did

sudo apt-add-repository ppa:ehoover/compholio

sudo apt-get update

sudo apt-get install netflix-desktop

after i did the last step it said it couldnt find the package.

posted on Sep, 17 2014 @ 08:54 AM
a reply to: CardiffGiant
You also need to install wine

posted on Sep, 17 2014 @ 08:55 AM
i just tried to install wine from the software center and i a message about package dependencies..

im so lost

posted on Sep, 17 2014 @ 08:58 AM
a reply to: CardiffGiant
All dependencies should be installed with these packages

posted on Sep, 17 2014 @ 09:00 AM
a reply to: CardiffGiant

Have you tried the command line? Apt-get is a wonderful tool

apt-get install wine

should pull in all dependencies and give you a working environment. If you have a 64 bit system then it would probably be:

apt-get install wine64

Hope it helps!

Disclaimer: I use Debian so you might have slightly different package names in Ubuntu, which is based on Debian.

ETA Above poster linked a Ubuntu specific article which might be more help to you.

edit on 17/9/14 by LightSpeedDriver because: ETA

posted on Sep, 17 2014 @ 09:09 AM
a reply to: LightSpeedDriver

I am on Mint with this computer, Debian as well on another, but I did have Netflix Desktop on here at one point, the steps were basically the same. Pipelight and mscorefonts are also dependencies, but from what I remember, the packages took care of everything for me.

I don't use Netflix any more, no sense of paying when everything is free on the internet (cough 1chan cough). I watch everything through XBMC media player which has loads of addons for all kinds of entertainment

posted on Sep, 17 2014 @ 09:16 AM
Put your foot against it and download: popcorn time. the best I have to offer anybody.
It's free :-) ...just as Linux :-) and there's a Linux version.

posted on Sep, 17 2014 @ 09:18 AM
a reply to: AllSourceIntel

i ran the commands from this link and got a little further.
i made it to an EULA... it opened that EULA in terminal and now i cant close it out.

at the end it says

i types yes, y, wont go away.

anyway, the next step was open netflix from dash but when i type in netflix it still is not there..

posted on Sep, 17 2014 @ 09:40 AM
a reply to: CardiffGiant
Was the EULA for mscorefonts or silverlight?
You might also have to switch to Firefox browser

To install corefonts:
sudo apt-get install ttf-mscorefonts-installer
a license agreement will appear

To install silverlight (Netlfix will not work without it):

Keep troubleshooting and you'll get if figured out. uninstalling everything you just put on via synaptic (right click - completely remove) and starting over might be an option worth considering.

posted on Sep, 17 2014 @ 12:11 PM
Netflix now works on linux? I'm dual booting again for netflix so mostly in windows when I prefer my linux box. But we don't have cable so netflix and a few other places is our primary tv shows.

posted on Sep, 17 2014 @ 01:08 PM
pretty much with most linux commands that change things such as adding/removing software or editing a core file you'll probably have to use sudo before the command unless you enable root login which isn't recommended but can be usefull when dealing with some scripts where the sudo command will time out remembering the password but thats on long running scripts.

linux at the command level is very powerful and for anyone used to gui's can be very daunting, i'm used to mainframes so it doesn't bother me generally, theres normall man pages so just type 'man command' and something will appear and just press q to quit and don't worry most software doesn't ask you are you sure at command level its like well you said to do something so enter your password and lets get started and i hope you know what to do

posted on Sep, 17 2014 @ 03:24 PM
a reply to: Unity_99
It has for some time but requires special software (as noted above) to get around the requirement of silverlight. If you are using windows only for Netflix I recommend downloading XBMC for linux. It has many addons and you can watch pretty much anything on demand, as well as a bunch of user submitted streaming channels. You'll have to look into it to see if its right for you and find the addons you'll want - there are officially supported ones and user affiliated ones.

posted on Sep, 17 2014 @ 03:52 PM
So does a neflix desttop become its own special mode of desktop that you need sign into at the beginning?
I made World of Warcraft work in linux for yearrs with wine and sims, without playonlinux. No wine is pretty cool. It nees the MScore fronts and things put in. But in this case, does this become its own desktop?

I use pclinux and mint linux, have tried numerous distros and those 2 are the best if you can't build one up from the ground up as some can on lighter systems.
edit on 17-9-2014 by Unity_99 because: (no reason given)

posted on Sep, 17 2014 @ 04:00 PM
a reply to: Unity_99
Not its own desktop, it will use the browser in fullscreen mode.

If you are looking at building your own linux, I would look at which uses opensuse as a base

new topics

top topics


log in